The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
NSUndoManager 10.6 Alert Thread Tools Search this Thread Display Modes
Hi,

I've updated to the last version (5.4) and so far performance is great. I've found a bug though that launches an alert window with the following message:


PHP Code:
_endUndoGroupRemovingIfEmpty:: NSUndoManager 0x10d681c30 is in invalid stateendUndoGrouping called with no matching begin
This happens when I group several components together and I try to manipulate (move around) the grouped components. The program launches the above message a couple of times and I have to ok the window before I can continue working.

Is this happening to everyone with the updated code??

Thanks!
 
The message won't stop until restarting the app

Meaning that I have to stop working and restart the app every time this happens, and it has happened a few times in a couple of days.

I suppose this is an important bug...

Anyone having the same problems??
 
It happened to me too!

Only after I updated to OG 5.4, I am on OS 10.7.4...

I had started another thread by mistake, but I think the error is the same:

http://forums.omnigroup.com/showthre...emovingIfEmpty

I got this bug after grouping components in the canvas, and trying to use either magic mouse or trackpad to scroll on the document.

I got these messages from the console...

Code:
6/15/12 1:01:31.224 PM OmniGraffle Professional: _endUndoGroupRemovingIfEmpty:: NSUndoManager 0x10af86710 is in invalid state, endUndoGrouping called with no matching begin
6/15/12 1:01:31.527 PM OmniGraffle Professional: _endUndoGroupRemovingIfEmpty:: NSUndoManager 0x10af86710 is in invalid state, endUndoGrouping called with no matching begin
6/15/12 1:01:34.167 PM OmniGraffle Professional: _endUndoGroupRemovingIfEmpty:: NSUndoManager 0x10af86710 is in invalid state, endUndoGrouping called with no matching begin
Finally, as it has been mentioned by others, this bug is making my productivity plunge as I have to restart the app every time it shows...

Thanks!

Leenyx
 
Same to me …*

22.06.12 10:21:39,315 OmniGraffle Professional: _endUndoGroupRemovingIfEmpty:: NSUndoManager 0x1177cd620 is in invalid state, endUndoGrouping called with no matching begin

just started to work with it..

rgds
Hannes
 
Same problem here. Started since I upgraded to 5.4. I am running Lion with latest updates Macbook Air with trackpad and/or Bluetooth mouse both have the problem. Occurs when scrolling with Trackpad or magic mouse. Also when Zooming using Command-scroll on mouse.

If I start OG for the first time after reboot then I see the problem whenever I scroll or zoom. If I then exit OG and start it again, the problem seems to go away!?!?!?

Last edited by mattheys; 2012-07-11 at 02:07 PM..
 
If one of you can drop us a line at support@omnigroup.com, including a file along with a screenshot of the state of the canvas at the time of the alert, it'd be greatly appreciated.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniGraffle Alert M0RPHlNE OmniGraffle General 1 2012-06-19 10:07 AM
Customize alert sounds? SFF OmniFocus for iPhone 1 2012-03-14 04:55 AM
iPhone alert - where did that come from? fudster OmniFocus for iPhone 6 2010-07-01 04:03 AM
Odd alert Fundin OmniGraffle General 3 2009-03-11 10:03 AM
Desktop Alert brademcee OmniFocus 1 for Mac 2 2008-08-29 06:35 PM


All times are GMT -8. The time now is 07:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.