The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Update to Lion/10.7 disables mail clipping [A: reinstall plugin from OF's prefs] Thread Tools Search this Thread Display Modes
Hi there,

So far I cannot get mail clipping to work with Lion. Has anyone else had success here, or do we need to wait for an OF update?

Kind regards, Steve.
You have to "reinstall" the Clip-o-Tron 3000 (button on bottom right of clippings OF pref pane.)

Then it works!

Last edited by walterbriggs; 2011-07-21 at 01:32 PM.. Reason: punctuation
Except that attachments seem not to be transferred into Omnifocus using Lion - there are some difficulties with Lion transmitting email passwords, so this might be a function of using POP protocol instead of IMAP - but it would be good t hear if this is a general problem with Lion.
I discovered you also have to make sure that the Omnifocus/send to inbox option is checked in preferences/keyboard/keyboard shortcuts.

Last edited by Jody Severson; 2011-07-22 at 12:18 PM..
Sorry for the extra step that's required: whenever the Mail application is updated, it disables all the Mail plug-ins that are installed, even if they work fine. This is what stops the clip-o-tron from working as it was previously.

As folks mentioned, reinstalling the clip-o-tron from OmniFocus' preferences gets you back up and running.
I've tried to install the new plugin in Lion, but I'm getting this error:

The script handler failed.

Errors returned from handler <ScriptHandler:0xe41590 com.omnigroup.OmniFocus.ScriptHandler.Mail_with_Ma ilTags NSBundle </Applications/> (not yet loaded)>: {
NSAppleScriptErrorAppName = Mail;
NSAppleScriptErrorBriefMessage = "Can\U2019t get project of message id 3604480 of mailbox \"INBOX\" of account \"Media Lab\".";
NSAppleScriptErrorMessage = "Mail got an error: Can\U2019t get project of message id 3604480 of mailbox \"INBOX\" of account \"Media Lab\".";
NSAppleScriptErrorNumber = -1728;
NSAppleScriptErrorRange = NSRange: {3139, 7};
Originally Posted by joi View Post
I've tried to install the new plugin in Lion, but I'm getting this error...
It is a problem with the MailTags 3.0 preview and the MailTags clipper script in OmniFocus. I've discussed this with the MailTags developer to see if the problem is with the script or with MailTags, but for now uncheck the 'Mail with MailTags' option in the Clippings preference.
Whenever I try to add the Omnifocus bundle, I get the following error:

For example, “I tried to drag the framistan onto the hee-whackity, the application didn't respond for about 10 seconds, and then it crashed. This is the third time it has crashed while I was trying to do the same thing, and it only started happening since I installed CrashDoubler 7.8!”

I copied the bundle from my Snow Leopard time machine backup manually, and Apple Mail in Lion is saying how it's being disabled each time I start up Mail. Nothing I do on two systems seems to make the bundle get installed or work.
The error message I get from Lion's Mail.

Mail has disabled the following plug-ins:


Contact the makers of these plug-ins for versions that are compatible with Mail 5.0 and Message 5.0.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail clipping: no attachments in Lion [A: caused by change to in 10.7] lgallerano OmniFocus 1 for Mac 36 2014-02-20 05:04 PM
OS X 10.6.5 update disables OmniFocus mail plugin [A: Re-enable via OF's preferences] dmfresco OmniFocus 1 for Mac 7 2010-11-15 03:36 AM
10.6.4 breaks mail plugin [SOLVED: Install from Prefs] lhotka OmniFocus 1 for Mac 21 2010-06-23 03:03 AM
Mail 4.2 Breaks (Disables) OF Plugin MJWashburn OmniFocus 1 for Mac 1 2009-12-01 02:09 PM
OSX 10.6.2 update broke the Mail plugin [SOLVED: Reinstall using 1.7.5] alexknight OmniFocus 1 for Mac 12 2009-11-17 08:48 AM

All times are GMT -8. The time now is 08:25 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.