The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
scrollbars not added to tabs from redirected popups Thread Tools Search this Thread Display Modes
When I use my tumblr post bookmarklet, the popup is put in a new tab (as set in the prefs). If I go to a new page from that tab, scrollbars are never added.

This is a bit of an edge case, but its reproducible and has been really annoying me lately.

Here's the javascript of the bookmarklet so you can reproduce:

Code:
javascript:var%20d=document,w=window,e=w.getSelection,k=d.getSelection,x=d.selection,s=(e?e():(k)?k():(x?x.createRange().text:0)),f='http://www.tumblr.com/share',l=d.location,e=encodeURIComponent,p='?v=3&u='+e(l.href)%20+'&t='+e(d.title)%20+'&s='+e(s),u=f+p;try{if(!/^(.*\.)?tumblr[^.]*$/.test(l.host))throw(0);tstbklt();}catch(z){a%20=function(){if(!w.open(u,'t','toolbar=0,resizable=0,status=1,width=450,height=430'))l.href=u;};if(/Firefox/.test(navigator.userAgent))setTimeout(a,0);else%20a();}void(0)
 
Try this bookmarklet:
Code:
javascript:var%20d=document,w=window,e=w.getSelection,k=d.getSelection,x=d.selection,s=(e?e():(k)?k():(x?x.createRange().text:0)),f='http://www.tumblr.com/share',l=d.location,e=encodeURIComponent,p='?v=3&u='+e(l.href)%20+'&t='+e(d.title)%20+'&s='+e(s),u=f+p;try{if(!/^(.*\.)?tumblr[^.]*$/.test(l.host))throw(0);tstbklt();}catch(z){a%20=function(){if(!w.open(u,'t',''))l.href=u;};if(/Firefox/.test(navigator.userAgent))setTimeout(a,0);else%20a();}void(0)

Last edited by troyb; 2007-09-13 at 08:50 AM..
 
On the tumblr question, I can't see the 'Dashboard' or 'Add to friends' links in the top right of an OW window
 
oops, i posted the wrong bookmarklet before. it shouldn't hide the scroll bars now.
 
Quote:
Originally Posted by Splutter View Post
On the tumblr question, I can't see the 'Dashboard' or 'Add to friends' links in the top right of an OW window
I'm not sure what you're referring to here exactly. The pages look identical to me in OmniWeb 5.6 and FireFox.
 
This is how the links show in Safari:



they are not visible in OW (even when I try spoofing and playing with ad blocking etc.) but there is a white box showing in the tab thumbnail where they should be:

 
They seem to be loading fine for me. And it looks like there's a spot for them in that tab preview you sent. Do you perhaps have an ad block setting that may be getting in the way here?

Try turning off all your ad block settings in the site preferences for tumblr and see if the problem continues.
 
Quote:
Originally Posted by troyb View Post
Try turning off all your ad block settings in the site preferences for tumblr and see if the problem continues.
Yeah, I tried turning off all ad-blocking and style sheets - still no show.
 
Can you post a screen shot of the page itself? Are you seeing the empty image wells for where the buttons should be?
 
Well! It wasn't there when I opened the page, but I wanted access to the Dashboard so copied the link from Safari - added it to OW bookmarks and opened the page in a tab. When I went back to the tumblr page the link blinked into existence about 2 seconds after the page loaded!?



There is a white space in the tab where the 'Add to friends' button should be, but as this is my page I wouldn't expect that to show.

('Add to bookmarks' toolbar button has stopped working now but I'll start another topic about that.)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mountain Lion and Scrollbars HunterHillegas OmniFocus 1 for Mac 9 2013-02-26 10:47 AM
Open popups in background? maurus OmniWeb Feature Requests 0 2007-10-21 07:02 AM
5.6sp4: no in-context popups in eBay Ward OmniWeb Bug Reports 0 2007-07-08 11:46 AM
Popup blocking should always allow popups triggered from bookmarklets neilio OmniWeb Bug Reports 8 2006-07-07 07:41 PM
Toggle for blocking popups daiyi666@yahoo.com OmniWeb Feature Requests 6 2006-06-21 08:24 AM


All times are GMT -8. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.