The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Default review interval preferences not sticking Thread Tools Search this Thread Display Modes
I originally sent this as feedback in August [OG #325829], but I'm still seeing it in the 1.5 release candidate. I'm hoping it can get fixed before they wrap up this release.

It seems the "By default, review projects every..." setting under the Data preferences pane isn't being preserved between app launches. For example, if I set it to "months" and quit the app, when I launch the app and open the preferences again I see it set back to the default of "weeks".

The same problem exists with the numeric value: I set it to "4" and "weeks" (since 1 month doesn't stick), relaunch OmniFocus, and check the preference again and it's right back to the default "1 week" setting.

Essentially, it seems impossible to have a default review cycle of anything other than a week!

Anybody else able to reproduce this?

-Dennis
 
Quote:
Originally Posted by Toadling View Post

Anybody else able to reproduce this?

-Dennis
Me.

I'm on the latest build. 106053

It reverts back to 1 week upon relaunch for me too.
 
I set it to 2 days, quit, relaunched, and it went back to 1 week.
 
Reproduced on the latest latest build (106095) as well.
 
We think we have this fixed as of build 106165, so please let us know if you see any problems with it as of that build or later.
 
Looks good from here -- even remembers what I had set the default review interval to in my test! I'm guessing it would store the user's specified value, but never read it back from the plist file?
 
Quote:
Originally Posted by whpalmer4 View Post
Looks good from here -- even remembers what I had set the default review interval to in my test! I'm guessing it would store the user's specified value, but never read it back from the plist file?
Yes, I'm seeing the same thing. I wish now I had actually tested it further by creating some new projects. They probably would have had the proper default review interval even though the preference pane wasn't displaying the setting properly.

Well, no matter. Things seem to be working nicely now. Thanks, Omni Group!

-Dennis
 
I don't know the exact specifics, but it turns out it was in fact both storing and reading the value set in preferences, the preferences UI just wasn't reflecting it after restart.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Default review period jordy1984 OmniFocus 1 for Mac 1 2012-05-07 03:53 PM
Changing default Review Interval globally Colums OmniFocus for iPad 2 2012-03-08 10:38 PM
Next review default time? Taylorgus OmniFocus 1 for Mac 1 2008-08-15 05:37 PM
Date Columns in Default View not sticking joelande OmniFocus 1 for Mac 1 2007-12-17 01:38 PM
Preferences > Default Review Time > Fixed Frosty Crunch OmniFocus 1 for Mac 4 2007-10-05 09:23 AM


All times are GMT -8. The time now is 01:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.