The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Trouble with Mail Rule Thread Tools Search this Thread Display Modes
I am new to omnifocus and trying to get set up. I attempted to set the mail rule (the one that lets you send an email to yourself with +omnifocus) but I get the following error message:

MailTags versions up to 2.2b5 disables the creation of Mail rules via AppleScript, preventing enabling or editing of the OmniFocus Mail rule. If you are running this version, please uninstall MailTags, relaunch Mail, and try this again (at which point you can re-install MailTags).

The problem is that I don't have MailTags so I don't know why I am running into trouble. Any ideas?

Thanks!
 
Check the OmniFocus Clippings preference and make sure that 'Mail with MailTags' is unchecked as one of the clipping options and see if that helps.
 
It's unchecked. Won't even let me check it because I don't have mailtags.
 
My guess is that something caused an error when OmniFocus tried to install the new mail rule for you, MailTags versions of a certain vintage are known to cause an error, and it is just assumed that any error in the process is likely due to having an old version of MailTags installed. I think you could probably just install the Mail rule yourself and route around the problem, though it would be interesting to know why the error occurs.

In Mail, go to the Rules section of the Preferences and create a new rule. Here's a picture of what the OmniFocus-created version looks like:



The AppleScript it runs is buried within the OmniFocus application bundle. The path you want to stuff in there is:

Code:
/Applications/OmniFocus.app/Contents/Resources/MailAction.applescript
(assuming you have OmniFocus installed in your /Applications folder). If you check the Archive box, the Delete Message action is replaced by nothing (if you Archive to the Inbox) or a Move Message action (if you archive to a different folder).

If for some reason you are unable to create the rules by hand, you should definitely report that to the Omni support ninjas and have them help you take a look. There might be a clue there as to what is going on in cases such as yours that they can use to avoid generating a misleading error message, or maybe even fix the underlying problem.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with Mail Rule smartbugmedia OmniFocus 1 for Mac 29 2011-10-22 01:37 PM
Would like to use the mail rule... Finlay Boo OmniFocus 1 for Mac 3 2009-06-14 11:46 PM
Mail rule and bcc chinarut OmniFocus 1 for Mac 0 2008-07-23 02:41 AM
Mail.app and OmniFocus Mail Rule chinarut OmniFocus 1 for Mac 0 2008-06-28 09:26 AM
Adding Tasks Via Send To OmniFocus Mail Rule, Mailtags, & Mail Act-On reuben OmniFocus 1 for Mac 0 2007-11-18 06:07 PM


All times are GMT -8. The time now is 11:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.