The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Some data not syncing from iPhone to Mac / how to set sync frequency? Thread Tools Search this Thread Display Modes
Hi,

I'm syncing via iDisk and after the original setup and syncing have all my projects etc. on the iphone.

I then made some changes on the iphone but only some of the changes have synced back to my Mac. I've been updating my sneakypeeks in the hopes that it's a bug that'll get fixed...

Any clues or troubleshooting tips welcome.

Also, is there a way to set the frequency at which syncs happen (both on phone and desktop)?

Thanks,

Owen
 
Hmmm. Now - at last - it finally seems to be working.

A bit more detail:

I had created two new actions on the iphone and left them without a project. I then synced both iphone and then desktop and although the two new actions where in the Inbox on my iphone they did not appear on my desktop.

I added projects to the actions on the iphone and resynced both sides... they still didn't show up.

What I just did (after two Sneakypeek updates) was to replace the new project on the new actions in favor of a projects that had already existed. After resyncing both the new project (now empty) and the Action (now in a different project) showed up on the desktop.

I then tried to duplicate the problem but the new action and new project created at the same time both synced over...
 
I have been having similar problems: I had synced well to start (iDisk), but then today spent a lot of time updating on the iPhone. When I got back to my Mac, none of the changes synced. I tried a number of things, and nothing worked.

Then, for a reason I cannot explain, I got a message on the iPhone that the databases were of different types, and did I want to use the local or server database. I chose local and sync'd. When I launched OmniFocus on the Mac and attempted to sync, it gave me the same error, and I chose server. However, nothing changed.

I quit OmniFocus on the Mac and restarted it. I got the same error message. I chose server. This time, it sync'd.

WHEW!

However, something strange is going on with syncing!
 
I think what you saw ("when I got back to the Mac, none of my changes synced") might be explained by the behavior of the sync code. Whenever you make a change, OmniFocus (on either iPhone or desktop) does a sync a minute later, writing out the changes to the central repository on the iDisk, WebDAV server, or some other disk location and reading in any changes that were deposited by other instances. If OmniFocus is idle (no changes), it will do this every hour just to pull in any changes that might have been made elsewhere. There isn't any mechanism for forcing another instance to pull in the changes immediately except issuing the "sync now" command (cmd-ctrl-S on the desktop, not sure what you do on the phone). So, depending on the relative alignment of the 1 hour idle poll on one machine and when you make changes on another, you may not see the changes on the idle machine for up to an hour unless you force it to sync immediately.
 
Quote:
Originally Posted by whpalmer4 View Post
I think what you saw ("when I got back to the Mac, none of my changes synced") might be explained by the behavior of the sync code. Whenever you make a change, OmniFocus (on either iPhone or desktop) does a sync a minute later, writing out the changes to the central repository on the iDisk, WebDAV server, or some other disk location and reading in any changes that were deposited by other instances. If OmniFocus is idle (no changes), it will do this every hour just to pull in any changes that might have been made elsewhere. There isn't any mechanism for forcing another instance to pull in the changes immediately except issuing the "sync now" command (cmd-ctrl-S on the desktop, not sure what you do on the phone). So, depending on the relative alignment of the 1 hour idle poll on one machine and when you make changes on another, you may not see the changes on the idle machine for up to an hour unless you force it to sync immediately.
Thanks for pointing that out, and you're exactly right. I should have stated that I did multiple "Sync Now"s to try to get them to sync, went back and forth between the two devices to try to get them to sync up, and so on.

If I had to take a bet, I would guess that the Mac couldn't handle the fact that there were about 30 little update files on the iDisk.
 
Quote:
Originally Posted by whpalmer4 View Post
There isn't any mechanism for forcing another instance to pull in the changes immediately except issuing the "sync now" command (cmd-ctrl-S on the desktop, not sure what you do on the phone)
Isn't what the double arrow synch icon (between location + new item icons) does on the iPhone?
 
I, too, am using MobileMe. Like the OP I was able to complete an initial sync with only a couple of glitches.

This afternoon I added a number of actions to my iPhone copy's inbox (9 item). I would like to sync them back to my desktop to place them in the proper context and group using that interface.

I have used the Sync button on both the iPhone and desktop versions of the program to try to sync. None of my iPhone inbox items appear in my desktop version.

A couple of other small issues. Yesterday I was being told to ask which version of the DB to use each time. This may have been resolved. Also I randomly get an extra "Misc" folder inserted in to one version or another at random tmes
 
Add me to the list having this exact issue. I can add that the issue occurs when using an iDisk or a WebDav (OS X Server) connection.
 
Can everyone that's having this problem select Perspectives -> Remaining items and let me know if the actions show up?

If there's no error message coming back from the sync, one possibility would be that the actions were synced, but are being filtered from view by the settings under the view menu.
 
Quote:
Originally Posted by TripleM View Post
Also I randomly get an extra "Misc" folder inserted in to one version or another at random tmes
On each of your machines that are syncing, open the Data pane of the Preferences and check the "Default list for Single Actions" pop-up; if it's set to "Create when next needed", set it to Miscellaneous.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Syncing Frequency? torchy OmniFocus Syncing 1 2010-07-31 05:35 AM
How to start syncing and keep data from iPhone/iPod touch? [Answered: See thread] ewishman OmniFocus Syncing 2 2009-05-06 04:34 AM
Getting wrong data on iPhone after sync (cPanel; WebDAV) omnibob Other WebDAV 2 2008-07-28 07:49 PM
iPhone Sync Frequency Clarification jtynefield OmniFocus Syncing 1 2008-07-17 12:40 PM
Frequency of iCal sync? miniwarmth iCal Sync 1 2007-11-30 11:44 PM


All times are GMT -8. The time now is 11:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.