The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Update problem when clearing flags Thread Tools Search this Thread Display Modes
The little script below clears every flag in the database. It works, but seems to expose a bug in OF's display code. To wit:

1. Switch to a project mode window.
2. Flag a project or single action list.
3. Run the script and choose "Yes" to clear flags.
4. All flags will be cleared in the database, but the project or SAL flagged in step 2 will still show a flag. Its children, however, will not show flags.
5. Switch to context mode, then back to project mode.
6. The flag will no longer appear on the project or SAL from step 2.

[Also submitted as feedback.]

Code:
try
	set theResponse to display dialog "Really clear every flag in the OmniFocus database?" buttons {"Yes", "No"} default button "No" cancel button "No" with title "Clear Every Flag?" with icon caution
on error
	return
end try
tell application "OmniFocus"
	
	tell front document
		set flagged of (every flattened task whose flagged is true) to false
	end tell
	
end tell
__________________
Cheers,

Curt
 
Quote:
Originally Posted by curt.clifton View Post
The little script below clears every flag in the database. It works, but seems to expose a bug in OF's display code.
I remember a similar issue (perhaps related ?) involving the refreshing of the flagged icon on actionless projects.

http://forums.omnigroup.com/showthread.php?t=15293
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Change Request: Clearing Date ifoner OmniFocus for iPhone 1 2008-08-27 07:40 PM
Clearing history takes forever Stormchild OmniWeb General 3 2008-07-05 01:26 AM
Clearing autocomplete entries? Handycam OmniWeb General 2 2006-05-26 12:58 PM
Clearing History problem with SP7 TommyW OmniWeb Bug Reports 2 2006-04-29 02:15 AM


All times are GMT -8. The time now is 11:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.