The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Strange Clipping Problem Thread Tools Search this Thread Display Modes

I'm a new omnifocus user, and I'm having a strange clipping problem. I've read the sticky thread, and it doesn't solve my issue. I am using the standard shortcut (control-option-c), but when I use this shortcut in any external program (tried safari, mail, and MS word) nothing at all happens. The only exception is in word, where the text I select is replaced with a little question block.

I've checked my keyboard preferences, and the omnifocus shortcuts appear and are checked.

Any suggestions?
Oh, I am using OS 10.6.2 and Omnifocus 1.7.5, if that helps.
And my shortcut is sticking, so I don't appear to be having the same problem as some other users.

Last edited by lksalkeld; 2010-01-21 at 02:10 PM..
Your shortcut isn't actually triggering OF. The behavior in Word is evidence of this, since you're just typing over the selected text there. I don't know about any "standard shortcuts", since I've been on OF since before clipping existed. You might try a different shortcut to see if you can avoid a conflict. I use Command-Shift-comma (i.e., Command-< on a US keyboard) for clipping without any trouble.

Thanks for this. I changed my shortcut to command-.
Now the feature works for mac mail, but still does nothing in word or safari.
Any further hints?

Have you restarted those applications since changing/setting the shortcut? You have to do so for them to know about it.
In this case, Command-period is often used as a keyboard shortcut for the "Cancel" button in dialog boxes; depending on how each application handles keyboard events, they may not be passing them along to the services system for us to respond to, even if there isn't a dialog box open when you press it.

When you define the clipping shortcut in OmniFocus, does it appear next to the Send to OmniFocus menu item under the Services menu?

If the shortcut does appear there, it's set up correctly; basically, our services code has set up shop and is ready to accept events. Unfortunately, that doesn't guarantee we'll get them. We only get a chance to run that code on your selection if both the frontmost application and the services system in OS X send it along to us.

(I really need to update the sticky thread with a message that explains this; will do that tonight.)

In any case, if command-period is displaying in the menu item for the service, choosing another shortcut may work. For me, command-F6 gives a nice balance between "easy to trigger" and "unlikely to conflict with something else".

If the shortcut isn't showing up in the menu item at all, though, it's a different problem. If you contact the support ninjas, we'll be happy to help.
whpalmer4: I have restarted the applications in question and the whole computer. Hasn't helped.

Brian: I have tried at least 5 different short cuts. In some, I get nothing in any application, and in others, I just get Mail to work. IN all cases, "Send to Omnifocus" appears in the Services menu.

I haven't tried command-f6, so I'll give that a go. Otherwise, it's e-mailing the support ninjas I shall go. Thanks very much for the prompt reply!!

Edit: Tried command-f6 and it works in mail, but nothing else. So odd.

Last edited by lksalkeld; 2010-01-21 at 05:35 PM..
That's not one we've encountered before, but if the keyboard shortcut is working in any of the applications, everything we have control over is set up and working as expected. (As far as I know.)

This might be worth stopping by the genius bar at your local Apple store, if that's possible. If it does get figured out, please let me know - I'd love to modify the sticky thread with info on what's going on in case it helps other folks!
Hi Brian,

Looks like everything is sorted. You were correct that I wasn't selecting an uncommon enough shortcut. However, this compounded by the problem that Mac Office does not support using the systems shortcuts at all, which is why I couldn't get it to work. Hopefully they will update this in a future edition. Nothing more that the great ninja team can do for me, unfortunately!

Thanks for the help!
Thanks for the update - I added information on Office to the sticky thread. Appreciate the help!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange line problem SPA OmniGraffle General 1 2012-02-29 06:02 AM
strange ... mepossem OmniFocus 1 for Mac 1 2012-01-02 10:30 AM
Clipping Problem kevinplarson OmniFocus 1 for Mac 6 2010-07-23 01:10 PM
Problem using clipping with Omnifocus 1.7.5 and Firefox 3.6 fredslz OmniFocus 1 for Mac 6 2010-03-12 10:20 AM
Strange sync bug dvinnola OmniFocus Syncing 1 2008-08-13 10:02 AM

All times are GMT -8. The time now is 10:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.