The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Applescript - Activate Issue Thread Tools Search this Thread Display Modes
I'm having an intermittent Applescript issue with OF and even having recruited the QA folks at Omni are having trouble tracking the source of the problem down (maybe it's me?).

Basically when I run a simple activate command like -

tell application "OmniFocus" to activate

- it works fine sometimes but after a few attempts will start to abort with a "some parameter wasn't understood error". The problem seems worse if I try to embed the command in an Automator workflow. In either case it may or may not run, which is making tracking down the issue a real pain. It's almost like Applescript is caching an earlier broken version of the command from some earlier Beta of OF but I don't know enough about the internal workings of Applescript to know if this is true. For example if I load older compiled versions of Applescript for OF then it always fails first time.

Sorry if this sounds vague but it's not consistent in any way. Any help for anybody who better understands the inner workings of Applescript would be very welcome!

Screenshots - This doesn't work after a while (although does at first)

This works fine -

Many thanks.

Last edited by geoffbarrall; 2007-10-26 at 04:00 PM..
I had the same problem, so I thought about your post.

An old script was working, and suddenly showed the same error than you.

After some head scratching, it appears that Script Debugger is part of the problem.

Re-saving the script with Script Editor removed the error.

Are you using Script Debugger too?
Sadly no, I'm using Script Editor. Maybe if I switched to another tool it'll fix the issue although I am seeing the same problem with both Script Editor and Automator.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Omnifocus/applescript issue when setting context greeno OmniFocus 1 for Mac 3 2012-07-10 04:32 AM
Weird issue with AppleScript and "open" function einarnn OmniGraffle General 10 2011-10-10 07:03 PM
A strange new bug in OF applescript [A: Script Debugger issue, not OF's.] RobTrew OmniFocus Extras 4 2011-09-12 04:59 PM
Export issue / Modify the selection in a Document via AppleScript / Scripting Bridge Scifer_2008 OmniGraffle General 0 2008-10-08 07:06 AM
Issue using AppleScript "activate" command chucksense OmniFocus Extras 2 2008-02-10 08:10 AM

All times are GMT -8. The time now is 01:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.