The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OW 5.7 Doesn't loadup Thread Tools Search this Thread Display Modes
Hi,

The other day OmniWeb 5.7 refused to open up. The icon in the dock appears, the to menu bar changes to say Omniweb and has all the menus but the spinning rainbow ball just keep spinning, no webpage comes up. If I use force quit the 'Application is not responding' even though it's only been a few seconds since I opened it.

I know this isn't a problem which can be fixed by a 'press this button' solution but can anyone offer any advice please?

Many thanks

Andy Maxwell
[Powerbook g4 1.5, OSX 10.4.8]
ps I have used it for months with no issues and can't think what I might have done to upset it...other than perhaps install a new version of Java] but still that was a while ago.
 
Press Shift while launching OW, it will create a new workspace.
Then delete the previous one in the workspace window.
Or delete the workspace in ~/library/application support/omniweb/workspaces.

Last edited by sangheeta; 2008-07-04 at 10:41 AM..
 
Hey, thanks. That worked. I guess it was a one button solution after all.

How does this problem arise?

Thanks again
Andy
 
Andy - sorry for the inconvenience this caused! The problem can potentially occur when the 'on startup, open the pages that I had open when I quit' setting is enabled for your workspace.

If a page causes OmniWeb to hang or crash, it may have already been saved to your workspace, so when the browser starts up again, we load the troublesome page automatically, with results like you saw...
 
Yeah, that makes sense. Thanks for the info.

I had it again today with pages that worked last night. I loaded the browser up 5 times with the shift key with no joy. However, when I went loaded it up for the 6th time and at the same time opening up Console (the focus was now off omniweb) I worked ok.

Hmm.

Anyway, console was showing up this message

2008-07-09 20:12:10.022 OmniWeb[584] *** -[NSBundle load]: Error loading code /Users/andrewmaxwell/Library/InputManagers/CamiScript/CamiScript.bundle/Contents/MacOS/CamiScript for bundle /Users/andrewmaxwell/Library/InputManagers/CamiScript/CamiScript.bundle, error code 4 (link edit error code 4, error number 0 (Library not loaded: @executable_path/../Frameworks/CocoaScriptMenu.framework/Versions/A/CocoaScriptMenu
Referenced from: /Users/andrewmaxwell/Library/InputManagers/CamiScript/CamiScript.bundle/Contents/MacOS/CamiScript
Reason: image not found))




Could this be a possible reason for failure...and what is it?

Many thanks
Andy
Bristol, England
 
That looks like a camino plug-in is trying to load in OmniWeb. I'm not sure what effect, if any, that would have.

The way to check this would be to temporarily disable the plugin mentioned in the error message - move it to your desktop. Does OmniWeb start launching again? If not, the plugin isn't related.
 
Thanks for the speedy reply :)

I deleted camiscript and all is now well, no console errors and omniweb is all good again.

Thank you for your help, much appreciated.

All the best,
Andy
 
ps... omniweb is better than camino anyday :D
 
Hi,

Further to my previous posts on this, OMW is still stalling on startup even though I have a blank page as my start page.

I have followed the advice from

http://forums.omnigroup.com/showthread.php?t=8629

and deleted the history.ox file. This was 10.5mb in size.
I have also flushed the cache.

Hopefully this will solve the problem.

Anything else I can try?

Andy maxwell
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 02:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.