The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Distorted, unpredictable color in Acrobat Thread Tools Search this Thread Display Modes
I've created a bunch of vector artwork in Illustrator, which I have been copying and pasting from Illustrator over to the Omnigraffle stencil I'm using for my current project. The artwork then gets pulled from the stencil onto my canvases. Everything was working well until I exported my project to a multi-page PDF.

Despite the fact that the vector elements are all copies of the same thing from the stencil, they are appearing with different color throughout the PDF when the PDF is viewed in Acrobat. When the PDF is viewed in Preview, the color is fine. See here:



I am losing my mind over this, I have an early morning preso and need to get a clean copy of this exported for viewing in Acrobat. Here are my stats:

OS X 10.5.8
Omnigraffle Pro 5.2.2
Acrobat 8.1.4
Illustrator CS3

Thanks.
 
1 For tomorrow:
Acrobat is broken (I thought that was no secret). There is nothing to "fix" on the Graffle side.

I would do the pres on a Unix box (eg. Mac, Preview).

Or download a PDF viewer for windoze that is not broken; not bloatware.

2 For longer term:
From a couple of experiences that were similar. It is a combination of using layers and a not-terribly-good object (that you imported) in the stencil. I fixed it by re-assembling a clean pure-Graffle object, and put that in my stencil (instead of an imported object).

Your object looks dead easy to simply create from scratch in Graffle, and it will be a prettier object to boot.

Last edited by DerekAsirvadem; 2010-05-27 at 01:12 PM..
 
Quote:
Originally Posted by DerekAsirvadem View Post
It is a combination of using layers and a not-terribly-good object (that you imported)
Can you elaborate on this? What does Graffle consider a good or not-terribly-good object? I create all of my vectors in Illustrator because I don't just use them in Graffle. Does Graffle have known issues with certain kinds of vector importing? I mean, given that the object is so dead-simple, I wonder why there'd be a problem.
 
Quote:
Originally Posted by lem0nayde View Post
Can you elaborate on this? What does Graffle consider a good or not-terribly-good object?
It is nothing to do with "what Graffle considers". AFAIK, it handles [imported] vector graphics really well.
Quote:
I create all of my vectors in Illustrator because I don't just use them in Graffle. Does Graffle have known issues with certain kinds of vector importing? I mean, given that the object is so dead-simple, I wonder why there'd be a problem.
No issues that I have ever seen.

I repeat, the problem is in Acrobat, not in Graffle. Therefore you cannot fix it in Graffle.

For the longer term, keeping in mind that Acrobat is broken, and that it cannot read its own PDF vectors correctly [note, the colour is corrupted, not other attributes of the vectors], a work-around is to feed it simpler PDF vectors. Since you are feeding it with Illustrator-to-Graffle vectors, create simpler vectors in Graffle. If you were feeding it Illustrator vectors, create simpler vectors in Illustrator.

For the short, medium and long term, to eliminate this problem altogether, eliminate the creator of the problem. Get rid of bloatware that is known to be broken; only use tools that are not broken. Preview, etc. That way, you do not experience nasty surprises the night before a pres. Ever.

Last edited by DerekAsirvadem; 2010-05-27 at 02:35 PM..
 
Actually, this looks like it's probably an issue with color profiles in the PDF, and differences in how Acrobat and Preview handle mixed color palettes.

You'd do best to send the Graffle file along to us in support, but using ColorSync after the fact to convert the PDF to a PDF/X is the best workaround I can offer you at the moment.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Export to PDF is white page in Acrobat Reader heljan OmniPlan General 0 2012-12-16 09:00 AM
PDFs don't load: grey screen and acrobat icon migueld OmniWeb General 13 2008-10-10 01:57 PM
Acrobat 8.1 works in OW trode OmniWeb General 4 2007-06-07 11:48 AM
Acrobat 8.0 PDF plugin not working with OW mshalperin OmniWeb General 2 2006-11-06 05:57 PM
OmniWeb 5.5 + Adobe Acrobat = problems vocaro OmniWeb Bug Reports 8 2006-07-03 08:20 PM


All times are GMT -8. The time now is 01:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.