The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OF disk image should include Applications link Thread Tools Search this Thread Display Modes
I've gone about this a bit differently. MacReporter tells me there's a new build and a couple mouse moves starts the download when I so choose. The disk image mounts automatically. Once present, I use an Automator script from the Scripts toolbar which just closes OF, trashes the current copy, copies the new copy, unmounts the disk, trashes the download, and opens the new copy. A modification I'd like to make, but just haven't bothered to try to yet, is to use a watched folder for the download so the script will launch automatically. The process would start once I was prompted by MacReporter to open the updated sneakypeek page and click on the latest version.

It cuts the mousing around downódoesn't eliminate it, but it still lets me start the process when both I and a new build are both ready.

Last edited by pjb; 2007-07-22 at 05:03 PM..
 
Quote:
Originally Posted by Anthony.Calzadilla
Liz, what is the purpose of removing the old OF app into the "Omni Old" folder? Wouldnt confirming replace of OF in the Applications folder be enough?
I like to keep an old copy around, in case the new one is hopelessly buggy. None of the alphas have been, so it's probably extra work.

I am a belt and suspenders person. <grin>

--Liz
 
My update script will put the old one in the Trash, renamed with the build number attached so 1) you can have several in the Trash without them over-writing one another and 2) in case you want to revert to a previous build.

If I really wanted to keep them and not risk accidentally deleting them (i.e. if you are on a very slow internet connection and didn't want to have to re-download an older build, I'd probably rename the existing version to include the build number and then zip it and leave it in the Applications folder or move it to my downloads folder (which != my desktop)
 
Quote:
Originally Posted by curt.clifton
My work-around was to add the Application folder to my dock. Now I just drag the application from its window onto the dock icon, then confirm the Replace operation.
I store all of my personal apps in ~/Applications, especially OmniFocus; that takes care of having to confirm the replace option. I keep a shortcut in the Dock to drag things to, and Quicksilver finds ~/Applications just fine.
 
Quote:
Originally Posted by jelmore
I store all of my personal apps in ~/Applications, especially OmniFocus; that takes care of having to confirm the replace option. I keep a shortcut in the Dock to drag things to, and Quicksilver finds ~/Applications just fine.
If you change the line

INSTALLED_APP="/Applications/OmniFocus.app"

to

INSTALLED_APP="$HOME/Applications/OmniFocus.app"

in "get-omnifocus.sh" then it will use the ~/Applications/ folder instead.
 
Maybe I misunderstood something, but when the disk mounts and the small window appears, if you click the lozenger (top right corner) the side bar appears, and you can just drag into the applications folder.
 
Quote:
Originally Posted by schmidt4brains
Not a big deal, but the OmniFocus disk image is missing the link to the Applications folder, unlike all the other disk images for Omni products.
We've always planned to add that link before shipping 1.0; I'll add a note that you (and others) are missing it now and that we should consider doing it sooner rather than later.

Thanks for the feedback.
 
Quote:
Originally Posted by acid2
Maybe I misunderstood something, but when the disk mounts and the small window appears, if you click the lozenger (top right corner) the side bar appears, and you can just drag into the applications folder.
Yes but some of us are very lazy (myself included) and just want to be able to drag it right there without having to hit the lozenger.

[Personally I've had my /Applications folder in my dock since long before anyone put a link in their DMG, but I still use it when I see it]

PS to Ken - it's also missing from the OmniWeb betas...
 
Quote:
Originally Posted by Ken Case
We've always planned to add that link before shipping 1.0; I'll add a note that you (and others) are missing it now and that we should consider doing it sooner rather than later.
And there it is in this morning's build (89263, or the one or two before that)

:-)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronics stencil disk image won't open ahdavidson OmniGraffle Extras 3 2012-07-14 09:47 AM
"Due Soon" perspective doesn't include include the inbox? gonzojl OmniFocus 1 for Mac 14 2010-05-18 07:29 AM
Disk syncing: what disk formats are supported? catrijn OmniFocus Syncing 1 2010-03-03 05:49 PM
Disk Image unrecognized / or corrupt Brian_Maggi OmniOutliner 3 for Mac 2 2008-06-24 02:07 PM
Link Hand Disappears After Dragging an Image jashugan OmniWeb Bug Reports 6 2006-05-25 06:03 PM


All times are GMT -8. The time now is 03:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.