The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
omniweb's cache eating over 100 MB of HD memory Thread Tools Search this Thread Display Modes
since using omniweb sneakypeeks i recognized that my disk space was decreasing slowly. first i discovered that omiweb's disk cache in ~/library/caches/omniweb was growing to about 20 MB (i set "limit disk cache to 0 MB" in the history preference pane"). flush cache helped to get back my 20 MB. but still disk space was decreasing. i discovered, that the folder ~/library/caches/quicktime was about 100 MB in size. maybe this was caused by omniweb? because i never had this before using OW 5.5 sneaky peeks.
 
No it isn't OmniWeb (it could be any browser) - anything you view online using Quicktime is cached and this can and will take up masses of disk space depending on your setting in System Preferences>Quicktime>Browser:


Last edited by JKT; 2006-05-17 at 11:22 AM..
 
Quote:
Originally Posted by JKT
No it isn't OmniWeb (it could be any browser) - anything you view online using Quicktime is cached
However, the old OmniWeb wouldn't use the new QuickTime "webplugin" (it used the old "plugin") so it is possible that the problem is exacerbated by using the Sneaky Peeks.

Additionally, the SP's have several different caches because we still have our old caches as well as the new WebKit caches--we haven't yet resolved all the issues involved with sizing.
 
Printing pdfs with some inkjets (doesn't seem to affect laser printer) can eat up GBs of space with left over temp files.

I use Applejack from time to time and it seems the safest of any for removing caches.

A boot drive should have even more than the minimum free space of 15-20% - so with drives going for $100 - 125 for 200-300GB, disk space shouldn't really be a huge issue, though I do tend to keep ~/Library down to ~500MB and ~/ home folder is about 30GB.

In order to burn DVDs in iDVD you also want 24-32GB (unfragmented preferably) free space.
 
i disabled the quicktime cache. that should help now. thanks to JKT for the hint.
i'm looking forward to a sneaky peek of omniweb that does correctly size its cache to the limit set in the preferences.
 
I just wanted to update that I notice that SP12 insists on creating and writing to disk cache no matter that it is set to zero.

(I thought I had deleted it, only to notice today during a backup, that there was 20MB being copied.)

Is there something in WebKit that just refuses to disable caching to disk? I have never used disk cache in browsers since going broadband. FF seems the faster for not using disk space.

I deleted ~/Library/Caches/OmniWeb which had 4.2MB, relaunched and opened only a few threads on this forum, and already it is back up to 5MB.

Yes, disk drives are larger and faster. But.
 
This is pre-beta software. They acknowledged they still have issues to resolved. What more do you want?
 
To point out one of those little/big issues that I can't see has been mentioned or addressed fully maybe? ;-)

I DID find a way to disable disk cache (never worked in earlier versions though):

create a file with no extension "OmniWeb 5" and put it in ~/Library/Caches

In the past, it would still create a folder in spite of presence of such a file.

I use FF alpha all the time, going back to Mozilla 0.7 or something in 2001-2.
 
Quote:
Originally Posted by Mad Hatter
To point out one of those little/big issues that I can't see has been mentioned or addressed fully maybe? ;-)
It was mentioned a few posts up as an issue that still needs to be addressed. :rolleyes:
 
I ran into trouble with disk cache 18 months ago.
Quote:
On Dec 21, 2004

I was pretty sure this was the case. The reason for my asking is that I'm wondering if there is a problem with assigning zero to the cache setting. thats why I was wondering if you could change your setting to 1MB for the cache. This would give it an actual cap that i'm wondering if it will handle better. Sorry for not being clearer before.

I'm going to test my theory here on my end as well.

Thanks!
Troy
... so it isn't like it was ever 'perfect' or maybe even working properly.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniWeb's last days? sarasdad OmniWeb General 1 2011-12-15 12:26 PM
Tips on Recording Your Life? i.e. Exercise Log, Eating Habits, Reading Times, etc. HappyDude Applying OmniFocus 20 2011-04-09 10:42 PM
OmniWeb's interface icons Gustomela OmniWeb General 14 2007-03-20 08:46 PM
5.5.3 eating 100% of both CPUs Margolotta OmniWeb Bug Reports 15 2007-02-23 11:12 AM
omniweb eating the cpu sickbar OmniWeb General 10 2006-12-20 12:29 PM


All times are GMT -8. The time now is 11:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.