The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPad
FAQ Members List Calendar Search Today's Posts Mark Forums Read

iPad not syncing to Omni Sync Server Thread Tools Search this Thread Display Modes
Ok, I've had this working for a long long long time. I was a beta tester and everything..

Today, it won't sync. I've deleted the app and it's working on my phone and on my Mac, but it just seems to hang up when I try to get it working on the ipad.

It asked me if I want to keep the device database or the sync database, I say "Keep Sync Database" and then it just sits on the "Fetching Remote Database" screen.


PS: Now I get

Unable to synchronize database with server.

Unable to read document.

No root transactions found in "File://localhost/var/mobie... etc...

Cancel or Retry

Taping retry just pops the same message.
ok, I just beamed my settings from the Mac to the ipad again, this time, for the first time today (6 different times) it actually asked me for the password to sync. But it's still stuck on Fetching Remote Database. I know it's big, but it doesn't seem to be moving
Ok, I have put the ipad into restore mode and it's giving the same errors.

No joy! Have tweeted to @OmniFocus to explain I'm having issues. DOn't know what's going on.

Something else I've noticed is that if I go to OmniSync on the Mac and click the Show Clients button the ipad isn't listed.

Anyway to wipe everything out and start over? or is the ipad just dead?
Originally Posted by Egon View Post
Anyway to wipe everything out and start over? or is the ipad just dead?
To wipe everything and start over, go to the iPad's home screen and tap and hold the OmniFocus app icon until it starts to wiggle. An (x) button will appear on the app icon; tap on that (x) icon to delete the app. This will wipe everything having to do with the app from your iPad.

You should now be able to install the app again from the App Store, and configure it to sync your database again. If that still doesn't work, you might double-check that your iPad has free space available: maybe it's run out of room to download your database and that's why it's failing? If that's not the problem either, then I'd recommend calling our support humans on Monday (between 10am and 5pm Pacific Time) at 800-315-6664—it can be a lot faster to walk through possible problems and solutions over the phone.

Hope this helps!
I already wiped it, even went as far as wiping the entire ipad. still no joy
Sorry for the trouble! My gut says this is indeed related to database size, but contact our support folks via email or via phone at 800.315.6664 and we'll be happy to investigate this with you.
Nothing annoys me more than finding a post on a forum and not finding the answer. So here's how I got it work again.

I called tech support this morning and Rachel was great in walking me through a few things that I already done, but she wanted me to do it with a new compacted database. So I did that, but it didn't end up working. Not her fault, it's not a small file.

Anyway, couldn't get it working, so I thought I would try to manually push the database to OmniFocus in iTunes. I did that, and it started syncing. No problem. So I recommend exporting the database, as Rachel had me to, and then pushing that to the iPad over the wire (or Wireless Sync). If it's a big database.
This was great, thank you! It was the only way to get OmniFocus for iPad syncing again under iOS 7 Beta.

For others searching for this solution, here is exactly what I did:

(this is ALL on the MAC OmniFocus)
1. On MAC - archived old items (to remove some of the bulk in my 30MB database).
2. File > Export - export Database in omnifocus document format (sved to desktop)
3. File > revert to Database Backup. Then pointed to the newly backed up file on my desktop.
4. File > Replace Server Database - this "compacts" the local database and then replaces the one on the sync server with the compacted one

Then I went into iTunes, then within iTunes to the iPad and then to the APPS tab. Down at the bottom of the APPS tab is a File Sharing section.

Select OmniFocus from the list on the left in the File Sharing section. On the right you should see your OmniFocus files.
1. Select OmniFocus.ofocus file in the list
2. Right click on that fils and select DELETE
3. Hit the ADD button on the bottom right
4. Navigate to the file you backed up in Step 2 above

Let iTunes sync.

Now on the iPad, open OmniFocus. Your database should load up.

Go to the "Gear" icon > Sync Setup...

Select "Don't Sync" and then close.

Go back to the Sync Setup... > select Sync with Omni Sync Server. The if the iPad app asks you if you want to keep the device database of replace with the server, choose the DEVICE, not the server.

Everything synced and worked for me after that. I tested a new item on the mac and then hit sync on the iPad and it showed up. All sync issues solved.

Thanks for this thread and to OmniFocus tech support for helping me with this one.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
On iPad how to copy Dropbox files to omni sync server? sdardens OmniOutliner for iPad 0 2013-05-02 03:50 PM
Sync OmniFocus With DropBox? [Not supported, use the free Omni Sync Server instead] Lamike OmniFocus Syncing 26 2011-11-12 06:54 PM
iPad Update: Cannot sync with Omni Beta server Mixalis OmniFocus Syncing 6 2011-07-12 08:55 AM
Please add Omni Sync Server support [A: iPhone app supports the server. See thread.] StateMachineJunkie OmniFocus for iPhone 4 2010-11-30 01:29 PM

All times are GMT -8. The time now is 03:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.