The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iDisk/MobileMe/.Mac Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

iDisk syncing completely broken Thread Tools Search this Thread Display Modes
I have literally not been able to sync using iDisk for weeks now, and today is the first time I've had a chance to attempt to troubleshoot the problem. I started from scratch by turning off syncing on my iPhone, throwing out 1) the OmniFocus folder in the ~/Library/Application Support folder, 2) the OF prefs file, and 3) the OF file in the Documents folder on my iDisk, and yet when I launched OF from scratch (and had it create a new DB), when I try to sync with my iDisk account from my Mac I still get the error message "Unable to synchronize database with server. Operation could not be competed. Too many open files".

I then even tried deleting my iDisk setup and re-set-up my iDisk from scratch, and still have exactly the same problem.

So, I'm still without sync, and I don't want to switch to a Bonjour setup because I don't want to have to remember to launch OF on my iPhone every time I leave my house to force it to sync while I'm on the same local network. I'm tearing my hair out and am unbelievably close to switching to Things even though I far prefer OF's interface, because I just don't have time to deal with buggy software.
Sorry for the trouble this is causing - this post describes what worked for another customer having this problem.

I don't remember the exact cause of the problem, but my recollection of the general problem is that we're having trouble logging into the sync server. Somehow, we get trapped in a loop where we're trying to log in over and over without success. Once the loop proceeds enough, you get the 'too many open files' message.

I'm not sure if this is a bug on the server end, a bug on our end, or something outside of our control completely. If you mail the Support Ninjas, they can track down the details for you.
I'm having the same problem. Cannot register a new machine. Not resolved by the suggestions cited above (sign out of MobileMe and delete iDisk from keychain).

Any other ideas?
Hmmm... I seem to remember there being another cause of the problem, but I can't remember what it was. If you contact the support ninjas they can help out. Sorry for the inconvenience this is causing!

Last edited by Brian; 2009-03-25 at 03:32 PM.. Reason: multitasking leads to manners fail
Syncing is a big problem now. I wasn't having issues before, but now MobileMe syncing is completely and utterly broken. Since 1.6, I continually get an error about being able to open "root transactions." I've tried some of the solutions listed on forums to no avail. I've started from scratch, only to have the problem recur. I am not about to give up local iDisk syncing just to resolve this. I shouldn't have to give up core MobileMe functionality that I'm paying for just to make one app happy. Asking users to do so is ridiculous. You need to find other solutions.

Just to reiterate the other posters' point about jumping to Things. I completely agree with that. I have a lot invested in OmniFocus Family Pack and iPhone edition, but I will happily chuck them for something that syncs properly. Things, while not as convenient since it requires WiFi, syncs like a charm and I have not run into anything close to these issues. The speed of the iPhone client completely blows away OmniFocus for iPhone.

I will give Bonjour syncing a try to see if it works like Things, but I am really aggravated. For the amount of money spent on both versions of this app, it really should just work. I need to get things done, not spend lots of time digging through forums to get my GTD app to work as advertised.
Have you moved your sync data location into the Backup directory on your iDisk, as is suggested to be the solution for this issue? There isn't any evidence that OmniFocus is hosing your data; it is the MobileMe sync code that is suspect, because when OmniFocus is configured to sync in a location on the iDisk that isn't synced by the MobileMe sync feature, the problem does not recur. You can read about how to do it here. (Look for the "Tip on using Mobile Me")
Great tip - thanks a lot for that! I'll give that a try.
Dear lord. This isn't working either.

And I've switched to Bonjour (despite it's limitations) and it doesn't work either.

I'm ready to switch.

Synchronization has proven to be such an intractable problem, either speed, having to reset sync, etc.....

I truly don't know what to do.
Originally Posted by lmsergio View Post
Dear lord. This isn't working either.

And I've switched to Bonjour (despite it's limitations) and it doesn't work either.

I'm ready to switch.

Synchronization has proven to be such an intractable problem, either speed, having to reset sync, etc.....

I truly don't know what to do.
Two suggestions:

1) contact Omni's support ninjas via email to or calling 800-315-OMNI

2) actually post a little detail here, describing the problem you are having and what you have tried so far, software versions installed, size of database...
1Password uses a common folder instead a package approach. Maybe it can help to figure out what else can be made to fix the issue for good. See details here:

Using the "Backup" folder fixed the issue for me.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Security of OmniFocus idisk syncing macula OmniFocus 1 for Mac 1 2010-08-23 06:23 AM
Any ideas on how to stop the constant iDisk syncing? danielandrews iDisk/MobileMe/.Mac Syncing 7 2008-11-26 08:17 PM
1.1 OF iDisk Sync Broken laner19 iDisk/MobileMe/.Mac Syncing 17 2008-08-04 10:08 AM
SOLVED: Not syncing from iPhone > iDisk > Mac Roll OmniFocus for iPhone 13 2008-07-27 10:04 AM
iDisk syncing Treo iDisk/MobileMe/.Mac Syncing 7 2008-07-18 01:07 AM

All times are GMT -8. The time now is 06:55 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.