The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OW 5.6sp4: no form field completion Thread Tools Search this Thread Display Modes
The new OmniWeb seems to be working well for me, with one serious exception:

When typing into a form, the customary completion drop-down menu appears. But I cannot find any way to get the selected entry to appear in the form field. Return and Tab simply dismiss the menu, and the form field stays as-is.

Are others seeing this? I can't find a report.

[copy of formal feedback]
 
not sure if I got what you meant, but press down to get the suggestion marked and than enter ?
 
Here's the form field completion technique I'm accustomed to using with OmniWeb 5.5:

1. Begin typing in a field - a drop-down menu of choices appears.
2. Continue typing to narrow the choices in the menu.
3. Select a menu choice with the down arrow key.
4. Press the Tab key -- the menu disappears, the selected choice appears in the form field, and the cursor advances to the next form field.

With OW 5.6sp4, the menu selection does not appear in the form field.
 
Command+Option+E pops up the conventional Zoomed Form Editor. Is this what you are looking for?
 
This item is a listed as a known issue:
Quote:
Form data is not being restored between workspace launches.
I am not sure if this is causing your problem.
 
I had read the reports yskar and Chiller mentioned before submitting my formal feedback and posting a copy here.

Does form field completion work for other OW 5.6sp4 users?
 
It appears that you have to press Enter (not Return) to select the auto-complete option from the drop down menu. This is definitely a bug compared to prior versions of OmniWeb (where tab would cause the selection to be input).
 
Quote:
Originally Posted by JKT
It appears that you have to press Enter (not Return) to select the auto-complete option from the drop down menu.
JKT's report encouraged me to experiment a bit more. Indeed, the Enter key and (for me) the Return key will move the selected completion menu item into the form field. The Return key has the unfortunate behavior of sometimes prematurely submitting the form.

The only way I've found to select a completion menu item is the up/down arrow keys. Clicking a menu item with the mouse dismisses the menu but does not fill in the form field.

And, as JKT mentioned, the Tab key has the same erroneous behavior as the mouse.

[submitted as formal feedback]
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
5.6sp4 - 100% reproducible bug in form field yskar OmniWeb Bug Reports 0 2007-07-18 04:00 AM
Form text field doesn't always accept a text drop Ward OmniWeb Bug Reports 2 2006-06-18 09:12 AM
Using Shift+Tab does not move focus from Search Field to Address Field jashugan OmniWeb Bug Reports 3 2006-05-30 10:54 AM
Form Text Field editor missing in 5.5? dherren OmniWeb Bug Reports 2 2006-05-03 01:19 PM


All times are GMT -8. The time now is 07:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.