The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
What should I do about "Client has not been synced" warnings? [Fixed: see thread] Thread Tools Search this Thread Display Modes
The client "bender" has not been recently synchronized.
I know. I don't care. I sync OmniFocus across 4 Macs and one iPhone. Two of those are laptops and are not always on. But I need to keep them registered so they're good to go when I use them.

I understand it can slow down syncs. I don't care. I just grow very tired of the nag screens.

Is there a way to turn them off? I can't find anything in the Prefs.
 
Sync the things once a week and you won't have the complaints. Or are you saying that these machines go more than a week without being on?

If you have a client that you really don't expect to use for a while, you could simply delete its registration (after syncing it, of course). Then when you need it, turn sync back on and when it complains that the files don't appear to match any longer, be sure to select the server or remote copy.

There's no readily apparent means to change that warning interval. Use Help->Send Feedback to request one.
 
Quote:
Originally Posted by whpalmer4 View Post
Sync the things once a week and you won't have the complaints. Or are you saying that these machines go more than a week without being on?
That's what I'm saying.

Quote:
If you have a client that you really don't expect to use for a while, you could simply delete its registration (after syncing it, of course). Then when you need it, turn sync back on and when it complains that the files don't appear to match any longer, be sure to select the server or remote copy.
I guess I'll have to try that. It's not ideal, but it'll do.

Quote:
There's no readily apparent means to change that warning interval. Use Help->Send Feedback to request one.
I will. I don't even want to change the interval, I just want the "ignore" button to *actually* ignore it and stop telling me about it.
 
We keep bugging you because until those older client files are removed by a later sync or by nuking them, your sync database won't compact. We keep all the transaction files around all the way back to the least recent sync so we can insert transactions from that machine when it eventually does.

Those extra files make every sync for the machines that *are* synching take longer. If someone that doesn't understand what's going on selected a perma-ignore option, they'd create a situation where their synchs eventually became unbearable; they'd blame OmniFocus, not the checkbox they clicked in the Ignore dialog three months ago.

I'm pretty sure we have a feature request open for nagging less frequently, though; send the ninjas an email if you'd like to add your voice to it.

Last edited by Brian; 2009-01-14 at 03:33 PM.. Reason: clarification and nit-pickery
 
Fwiw, my real world experience of this issue occurred over the holiday period where I was away from my desktop for 3 weeks - once I got back, because it hadn't been synched to my Desktop for such a long time, my OmniFocus database on my iDisk had ballooned from a few kb to over 8MB in size and synching took forever. I actually thought it had corrupted so after the first synch, I ended up nuking my database on my iPhone, compacting the desktop database and going through the rigamarole of posting it back to my iDisk and setting up my iPhone again. Of course, it wasn't until afterwards that I read on the forums that this wasn't necessary and the way to 'solve' it was to allow both desk and iPhone to synch and repeat it again within an hour so that the compacting would be performed automatically...
 
This happens to me on what seems to be a daily basis. I get a notice saying it's been so long since my last sync of a client. It always happens when I'm trying to type and really bugs me. If I don't want to sync my device (iPhone) I shouldn't have to. I hate this warning. Please sort it out.
 
Quote:
Originally Posted by JKT View Post
Fwiw, my real world experience of this issue occurred over the holiday period where I was away from my desktop for 3 weeks - once I got back, because it hadn't been synched to my Desktop for such a long time, my OmniFocus database on my iDisk had ballooned from a few kb to over 8MB in size and synching took forever. I actually thought it had corrupted so after the first synch, I ended up nuking my database on my iPhone, compacting the desktop database and going through the rigamarole of posting it back to my iDisk and setting up my iPhone again. Of course, it wasn't until afterwards that I read on the forums that this wasn't necessary and the way to 'solve' it was to allow both desk and iPhone to synch and repeat it again within an hour so that the compacting would be performed automatically...
Doesn't this show that the Omnifocus "solution" is not really a solution but simply evidence of a flawed model of synchronizing? Another way of viewing this situation is that the choice to keep data all the way back to the oldest sync time is causing this situation. If that were relaxed or changed, the user would not need to be bothered. Omnigroup programmers take note -- a lack of programming foresight on your part should not constitute an emergency on mine. :-)
 
Quote:
Originally Posted by JKT View Post
Of course, it wasn't until afterwards that I read on the forums that this wasn't necessary and the way to 'solve' it was to allow both desk and iPhone to synch and repeat it again within an hour so that the compacting would be performed automatically...
By the way, the sync logic changes we're working on for OmniFocus 1.7 make it unnecessary to do this get-everything-in-sync-at-once song and dance. Sneaky peeks coming soon!
 
can we change it to a million years?

like the first poster, i don't care if my laptop that i rarely use hasn't been synced. and i don't care either about the iphone. until the rare occasion i want to use either. after reading this thread i understand the issues better, so thanks. but still i would prefer never ever to get that annoying warning and wait longer to sync when i do use those other devices. life is stressful. too much to keep in sync. on the laptop if there could be a daemon running that would solve it. on the iphone not so sure. the iphone sync situation generally sucks as you have to sync every app individually. palm was much better with conduits.

Last edited by ctawn; 2010-04-02 at 04:09 PM.. Reason: title didn't show up
 
ctawn, did you bother to read Ken's posts where he described how to set the behavior? It's all there. Just type in any 11 or 12 digit number that strikes your fancy and it won't bother you for years (except for your database getting larger and slower).

If you have clients you rarely run and don't care if it takes a bit longer for them to sync when they start, use the show clients display in the sync preferences on a machine you do use frequently and simply delete those rarely used clients. The client(s) you do use regularly will perform better, and the ones you don't use regularly will perform no worse.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Email-to-OmniFocus" entry in client list? [A: created by Sync Server's Mail Drop feature.] Robejazz OmniFocus 1 for Mac 1 2013-03-11 04:03 PM
Sync adds "Process" prefix to Perspectives [A: Bug, will be fixed in update. Sorry!] b-dr OmniFocus for iPhone 3 2012-09-24 12:56 PM
"Jump to specific canvas" action wrong in exported PDF? [A: Bug, fixed in 5.4.1] Georgy OmniGraffle General 4 2012-07-31 03:44 PM
Some synced events not appearing in iCal [A: check "add blocked items" in OF Prefs.] peterlemer OmniFocus 1 for Mac 2 2012-02-08 09:06 AM
"Existing sync client entries will eventually go stale"?? al_f OmniFocus Syncing 2 2008-09-12 02:11 PM


All times are GMT -8. The time now is 08:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.