The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Upgraded and lost needed stencils. Thread Tools Search this Thread Display Modes
Hello.

I felt the urge to upgrade my OmniGraffle from my old v3.5 to v5 pro for the visio support.

Since the change, two of the critical stencils that I used which were built-in to my old version of OmniGraffle were not included.

After browsing through the content of the old App's internal files (show package contents) I found the stencils.

When I copied these stencils into my "~/Library/Application Support/OmniGraffle/Stencils" folder and launch OmniGraffle 5, I get an error "File is empty or unreadable".

They are:
- Software > GUI Design.gstencil
- Business > Network.gstencil

How can I get these back? Is there a converter?

Thanks!
-Cheers, Peter.

Last edited by pbrunnen; 2011-03-30 at 12:14 PM..
 
Peter-
Hmmm... those stencils should convert over just fine. If you download a fresh copy of OmniGraffle from our ftp server and pull the stencils out of the folders inside the "InternalStencils" one, what happens?

When I did this, those stencils opened up and were installable. Graffle Pro 5.2.3 on a machine running 10.6.7...

<OmniGraffle App Package>/Contents/Resources/English.lproj/InternalStencils
 
There's also an InternalStencilImages folder not inside a language.proj which has a GUI Design.gstencil file that will elicit the reported error...
 
Hi Brian, whpalmer4,

You both hit the nail on the head! :-)
"InternalStencilImages" was the folder I pulled from.

So I pulled them over from the "<OmniGraffle App Package>/Contents/Resources/English.lproj/InternalStencils" path and they do load now without the error.

All but one works now. The last one references errors with missing images.

Thanks again!
-Cheers, Peter.
 
Hi Brian, whpalmer4, again...

No worries. I noticed the stencil files are also packages. I merged the images from the stencil packages in "InternalStencilImages" with the data plist in the "InternalStencil" stencil packages.

All good now.

Thanks for all your help!!

-Cheers, Peter. :-)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost data for no reason - Help needed! RedHead OmniFocus for iPad 2 2012-05-22 08:07 AM
Upgraded document browser HappyCatMachine OmniGraffle for iPad 0 2012-05-01 05:10 AM
Old-format transactions must be upgraded before opening. anakin44011 OmniFocus 1 for Mac 15 2008-07-19 09:56 AM
upgraded to 1.0.2 and can't open my database! webalstrom OmniFocus 1 for Mac 6 2008-05-21 06:35 AM
Powerpoint Like Stencils Needed jackl73 OmniGraffle Extras 9 2007-05-06 02:42 PM


All times are GMT -8. The time now is 10:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.