The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniWeb freezes more and more often Thread Tools Search this Thread Display Modes
Its an old story that OW was always "behind" the Safari Webkit development, still there are numerous sites rendering well in Safari but not in OW.

I could live with this as the features of OW were still superior for my needs. However since some time now its not only misplaced rendering. More and more often OW simply freezes driving the CPU load to 100%, no crash reports, no log entries..

I guess this is the evolution of Javascript, HTML5 etc. which OW is not able to catch up with especially now thats it is a free product.

I am now seriously considering to end my love relationship with OW and switch to Safari or Firefox. But I still would hope that OW evolves further and can eliminate the reasons for these freezes.

prominent example fors such a freeze-page is "www.flattr.com" or the good Readability Java Script from lab.arc90.com

This is with all OW Versions >=5.10 working on OSX 10.6.8
 
I'm using OW 5.11 and Mac OS X 10.6.8. I just went to www.flattr.com and the page loaded with no problems in just a couple of seconds and as far as I can tell from the source code that site is still on HTML 4.
It may be that you have a problem elsewhere or maybe your Java or other software needs updating.
Also try doing a Repair in Disk Utility as it might be that something needs fixing there.
 
Thanks for this test. Would be happy to find the cause somewhere else. The fact that OW freezes and not just crashes might be an indication for an OSX problem but its hard to trace without any error messages.
My guess its something with JavaScript but that would be part of WebKit...
 
Here is another page with freezes OW:

hicksdesign.co.uk

I disabled all plugins -> no effect.
 
All of the mentioned pages appear to load okay for me when done in a newly-opened copy of OmniWeb. When OmniWeb runs out of address space, it often behaves similarly to what you describe; are you using a workspace that has lots of tabs and windows open? Next time, when it freezes, before force-quitting the app, use the Activity Monitor to select the OmniWeb process, click on the Inspect button, and the Memory section in the resulting window. See what it reports for Virtual Memory Size. If that number is 3.95 GB or larger, you have run out of address space. Loading pages with "complicated" content chews through the address space faster than simpler pages that aren't monuments to how clever the web designer is...

I would try launching OmniWeb in a new workspace (hold down the shift key when launching it) and visiting those pages. I think there's a good chance they will work properly, but if they don't, you've narrowed the problem down a bit.
 
It's possible that OmniWeb is hanging because ad blocking (specifically the option to block content "from blocked URLs") is getting stuck on the embedded fonts in the pages you mention. If OW still hangs with ad blocking disabled, can you email omniweb@omnigroup.com or do Help > Send Feedback?
 
Dave you are a genius ;-) Disabling the ad blocking solves the problem!! All mentioned pages now load without any issues.
I will of course use now one of the best OW features: disabling ad-block per site. But is there something a future OW version can do about this? Its somewhat strange that a browser freezes because of ad-blocking...

Thanks a lot, Mike
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus Freezes while Syncing over Slow Network Connection supernitin Syncing via Omni Sync Server 3 2013-04-05 07:13 AM
iCal import file freezes iCal w0rld OmniPlan General 4 2010-09-07 10:08 PM
10.5.2 freezes - OmniGraffle connection? retropc66 OmniGraffle General 16 2009-03-16 04:36 PM
OmniWeb Freezes on Startup texeter OmniWeb Bug Reports 3 2009-02-02 10:27 AM
Status Bar display freezes (sticks) ericob OmniWeb Bug Reports 3 2006-08-14 07:44 PM


All times are GMT -8. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.