The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Activities not displaying with new build Thread Tools Search this Thread Display Modes
It is not entirely clear to me when this happened, but today after I downloaded the most recent build and since I did an iCal sync I can no longer see most of the activities. The only one I can see is the first sub-project in the first project. Changing the view options does not help, rebuilding the database does not help, restoring a previous good database does not help.

The only thing I did was change my preferences to specify the hierarchical name ... but unchecking that has not made any difference.

I'm pretty sure that the data is still there because the file size is still more or less the same.

Has anyone got a suggestion about how to fix this?
 
Well the answer was simple but I do not think it should have behaved this way. I had done a search ... and did not notice that the search field was not being cleared out. I think that it should be cleared when the application is restarted or when you change focus etc. which is the behaviour in most other applications.
 
We originally had the search string persist more than it did now, and we are backing off of that over time. The goal was to avoid the behavior Mail has where you enter a search in the toolbar and then switch folders, realizing that you filed the message somewhere else, and it clear the search. You then have to type it in again which is annoying.

It could still be useful for someone to save a perspective with a search string in place, though maybe that isn't worth the confusion this causes on occasion.

We have an existing bug for this issue, <bug://bugs/43038> (Don't persist search tool contents through restart), and I've attached this thread to the bug.
__________________
CTO, The Omni Group
 
Quote:
Originally Posted by Tim Wood View Post
...the behavior Mail has where you enter a search in the toolbar and then switch folders, realizing that you filed the message somewhere else, and it clear the search. You then have to type it in again which is annoying...
yes, very.

Quote:
Originally Posted by Tim Wood View Post
...It could still be useful for someone to save a perspective with a search string in place, though maybe that isn't worth the confusion this causes on occasion.
I would make use of that.

I put the search bar to the left in the toolbar and find that it's much easier to notice if it's filled or not since my eyes don't have to dart between the project list and the search field.
 
I should also note that we've tossed around having the search field draw in a more distinct fashion if it has a string in it, making it more obvious that you've filtered your results.

If this is something that'd help, make sure to tell us with Send Feedback.
__________________
CTO, The Omni Group
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Build Framework Fails From Command Line But Build in XCode Succeeds davidbitton Omni Frameworks 2 2012-05-01 04:13 PM
Integrating OmniFocus Contexts with Concentrate 'activities' RobTrew OmniFocus Extras 1 2012-04-16 12:56 PM
Signle-actions lists and related activities BK_man Applying OmniFocus 2 2010-05-25 07:02 AM
Using OF to Track Activities beyond tasks? marshallj Applying OmniFocus 4 2009-06-22 07:39 PM


All times are GMT -8. The time now is 01:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.