The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Feature Requests
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Please fix the HTML source view Thread Tools Search this Thread Display Modes
I've been waiting for year, yes years to have this fixed and it is still broken in many ways.
  1. OmniWeb would not for anything in the world use the font in the source view that I tell it to. Even if it's a nice monospaced font like Panic Sans or Bitstream Vera (which are identical btw)
  2. OmniWeb source view doesn't understand XHTML properly. tags like <img /> and <br /> are considered wrong. Come on guys it's 2008 already. What use is a source view if it doesn't understand the prevalent version of HTML/XHTML in this time and age?
  3. The source view doesn't automatically respect the encoding stated in the HTML itself. Say I have OmniWeb set to automatically detect encodings and I have a page encoded in EUC-JP. If I open the source view for this page the Japanese will be scrambled (with 100% certainty). I always have to manually switch to whatever the page's encoding is, reload the page then open the source view. Finally it displays correct. This is just broken and has been for an incredibly long time.

I do love OmniWeb, but if even after 7 minor version changes this kind of essential basic stuff doesn't get fixed, I really wonder what's going on here...
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Source View doesn't like Vera Handycam OmniWeb Bug Reports 3 2008-04-20 05:58 AM
How de we view the source clipping ? laurentsj OmniFocus 1 for Mac 1 2008-01-14 12:59 AM
Source View encoding agnostic arglborps OmniWeb Bug Reports 0 2007-05-08 08:41 PM
Source View not obeying colors set in HTML Source Editor jashugan OmniWeb Bug Reports 0 2007-05-02 04:36 PM
Source View window will not close shpoffo OmniWeb Bug Reports 1 2006-07-04 12:43 PM


All times are GMT -8. The time now is 11:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.