The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Omniweb in 64-bit? Thread Tools Search this Thread Display Modes
Good grief. If you want the latest software you at least have to be on the modern architecture! ;)
 
Quote:
Originally Posted by Vanceone View Post
Or are PowerPC users just going to be out of luck entirely, and 5.10 is the end of the line?
Every line has an end.

Just like 680x0 chips were left behind, and OS9, so will PPC. It's the circle of life.
 
Indeed, every line may have an end, and yes, it is time to have a new archetecture, but I seem to recall that Safari, Firefox, Camino, etc--all have PowerPC builds still and none of them have announced plans to orphan the PowerPC platform yet.

It will happen at some point, but considering that up until last month I on a powerPC could still get the latest operating system from Apple, it seems a bit soon to junk the entire platform just quite yet.
 
I think I need to clarify, we aren't dropping PowerPC support. Just Tiger support. You'll still be able to run OmniWeb on PowerPC machines that use Leopard. At least for the time... there is a good chance that OmniWeb 6 will require Snow Leopard.

We would love to continue supporting Tiger and Leopard forever but we simply don't have the man power that some of the other companies you mention have to do this.
__________________
Troy Brandt
Omni Person

Last edited by troyb; 2009-09-21 at 08:52 AM..
 
Quote:
Originally Posted by troyb View Post
I think I need to clarify, we aren't dropping PowerPC support. Just Tiger support. You'll still be able to run OmniWeb on PowerPC machines that use Leopard.
I'll clarify your clarification: you'll be able to run the latest versions of OmniWeb on PowerPC machines that use Leopard. You'll be able to run the current versions (and any more released before dropping Tiger support) on any machine that can run them now for as long as you like. It's already a pretty nice browser, you know :-)
 
I don't think many users use tiger anymore do they as it is quite old now, those who use tiger are usually those who will not buy leopard because they do not want to pay for it, OmniWeb used to be a premium browser therefore most tiger users you have using it (if any), will have probably come along since it became free, I am sure 95% of users with OmniWeb are on leopard.
 
Leopard required an 867 MHz G4 or better. Earlier machines ran Tiger and OmniWeb just fine if you didn't push them too hard. My main machines still run Tiger most of the time, because upgrading to Leopard would have required large outlays to upgrade other software that didn't get used quite often enough to justify the cost, but not so infrequently that doing without would have been convenient. I also support a group of friends and relatives who had no reason to upgrade to Leopard, and it is much easier to support someone when you've got a machine that runs the same software. I do also run Leopard and Snow Leopard, and have used OmniWeb since before it was free. I think that was all of your assumptions, wasn't it? :-)

My interpretation of the graphs at http://update.omnigroup.com/ is that about 20% of the OmniWeb population is using Tiger, and the rest is split pretty evenly between Leopard and Snow Leopard. For my part, I understand that at some point it will not make sense for Omni to produce any more Tiger-compatible versions of OmniWeb, but as it is a free program now, I look at each new version as a gift. If yesterday's version was good enough for my needs it will probably remain useful for quite some time even if it never gets another update.
 
The point is, even if NEW versions of software do not run on older operating systems, the OLD versions are still pretty good and will continue to work indefinitely. You can still run older versions of OW, Safari, Camino, Firefox, even Netscape.

But if people really want to take advantage of new web technologies and other advances, it makes sense that they will want to upgrade whatever is important to them and can afford to.
 
Well, I'm glad PowerPC support is not being dropped until Omniweb 6, at least.

Still, you'd be surprised at how well Omniweb 5.10 is running on Tiger on my Pismo. The new webkit still handles ye old G3 well. I understand that the time will come when of course we are left out in the dust (just like Adobe's abominable implementation of Flash means that pretty much any processor under 1 GHZ is not able to do it--including the iphone).

I'm not necessarily asking that we older users get all the nifty processor dependant features, or even core technologies that require 64 bit, etc. However, I think that as long as Safari includes Tiger support, I think we could at least keep a branch of Omniweb that has the latest webkit for those people still using Tiger on PowerPC. That includes almost every G3 and several years of g4's that cannot run leopard, but are otherwise still capable machines.

We are, after all, running on Macintosh, which has amazing longevity. A g4 is roughly the same power as an iphone, right? We aren't out of the running quite yet!
 
Quote:
Originally Posted by Handycam View Post
Every line has an end.

Just like 680x0 chips were left behind, and OS9, so will PPC. It's the circle of life.
If tiny circuits etched on six-9 silicon qualify as "life".

If you don't have the money, it's understandable. If you have the money, throw caution into the wind and upgrade. The time is right. It will be worth your while. PPC is wonderful, but intel has made the switch worthwhile.

And, man, oh man, is Snow Leopard fast!!!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to Omniweb & need help! Kisal OmniWeb General 6 2012-11-07 03:22 PM
OmniWeb 5.11.2 is now available troyb OmniWeb General 5 2012-08-01 08:53 PM
OmniWeb 5.5.4 now available. troyb OmniWeb General 4 2007-02-24 06:30 PM


All times are GMT -8. The time now is 03:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.