The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Windows at work and Mac based GTD Thread Tools Search this Thread Display Modes
I have Windows machines at work too.

I don't bother using the work machine for GTD management.

I have an iPad with OF for iPad that I use instead (I used to use an iPod Touch with OF for iPhone/iPod Touch, and still use from time to time to be sure I have my lists and ubiquitous capture with me when the iPad is impractical)

The various OF's sync very nicely and the added expense of a an iPod Touch and OF software would be worth it, over this kind of kludge.
 
First of all thanks a lot for this very useful scripts.

I used IE8 on Win7 in VMWare to test it and when hitting Win+T (or Win+Shift+T) nothing happens. I had text selected in the website and the location bar as well as no text at all. Hitting Win+O works great.

Any suggestions?

BTW, how to get rid of the Yojimbo stuff? I donít use this program and Iím already using conflicting shortcuts for other AHK scripts at work.

Thanks in advance.
 
Quote:
Originally Posted by kingsinger View Post
After I enter the data. I hit ok and it says Request qued. But when I look in the assigned dropbox folder, there's nothing in there.
Kingsinger, I may have found your problem. There's a sequence bug in the script that causes the working directory you set to not be used if it doesn't already exist, even though that's a condition I accounted for. Chances are all the files you generated are sitting in the same directory as the script. Please take a look and let me know if that's the case.

I'm posting a new version of the tool in a few minutes that will have a fix for that.
 
Quote:
Originally Posted by Dalmet View Post
I used IE8 on Win7 in VMWare to test it and when hitting Win+T (or Win+Shift+T) nothing happens. I had text selected in the website and the location bar as well as no text at all.
The "Task" shortcut only fires if Firefox, IE, or Outlook are the active window and you've already said you're in IE. The script you have knows IE is active by looking at the window title for the string "Microsoft Internet Explorer". Well, it turns out that my employer gives us a modified version of IE with that title. The real IE has the title "Windows Internet Explorer". I'm posting a new version of the script in a few minutes that will include a fix to inspect the window class instead of the title for IE. That should fix your problem. Thanks for reporting it.

Quote:
Originally Posted by Dalmet View Post
BTW, how to get rid of the Yojimbo stuff? I donít use this program and Iím already using conflicting shortcuts for other AHK scripts at work.
Glad you asked! The new version of the tool I'm posting in a few minutes uses an ini file for customization and lets you easily change the key combinations for each hotkey action. Setting one to an empty value will disable the function entirely.

Last edited by GrumpyDave; 2011-02-17 at 10:18 PM..
 
I've updated the file in the first post to v1.2
  • Moved all the configuration options to an ini file on Windows to make future script updates easier.
  • Added the ability to change the keystroke combinations for each hotkey action. Setting any key sequence to a null value will disable the action. This is handy to disable Yojimbo if not needed or to map your Windows and Mac shortcuts to the same keys where possible.
  • Changed the naming convention of the transaction files.
  • The folder action script on the Mac now silently ignores unrecognized files.
  • Now includes a pre-compiled standalone executable of the Windows script. You no longer need to install AutoHotKey. The script is still included if you prefer to run from source. There is no performance gain either way.
  • Fixed a bug where the working directory would not be used if it didn't already exist.
  • Fixed a bug where Internet Explorer wasn't being recognized for anyone but me.

Note: The pre-compiled script executable had to be removed from the posting due to file size restrictions. I'll be asking Omni if the limits can be changed.

Last edited by GrumpyDave; 2011-02-17 at 10:19 PM..
 
Quote:
Originally Posted by GrumpyDave View Post
Kingsinger, I may have found your problem. There's a sequence bug in the script that causes the working directory you set to not be used if it doesn't already exist, even though that's a condition I accounted for. Chances are all the files you generated are sitting in the same directory as the script. Please take a look and let me know if that's the case.

I'm posting a new version of the tool in a few minutes that will have a fix for that.
I'll check.
 
Quote:
Originally Posted by GrumpyDave View Post
Kingsinger, I may have found your problem. There's a sequence bug in the script that causes the working directory you set to not be used if it doesn't already exist, even though that's a condition I accounted for. Chances are all the files you generated are sitting in the same directory as the script. Please take a look and let me know if that's the case.

I'm posting a new version of the tool in a few minutes that will have a fix for that.
Yes, you are right. The tasks re in the directory with the scripts.
 
Quote:
Originally Posted by kingsinger View Post
Yes, you are right. The tasks re in the directory with the scripts.
Okay, thanks for checking. That confirms that you were hitting the bug I mentioned. The new version attached to the first post in this thread fixes that.
 
Quote:
Originally Posted by GrumpyDave View Post
Okay, thanks for checking. That confirms that you were hitting the bug I mentioned. The new version attached to the first post in this thread fixes that.
Just set it up with the new package. Seems to work. Is there any way to make it work with Thunderbird as well as Outlook on the PC? That would be kind of cool.

JL
 
I've updated the file in the first post to v1.3
  • Added support for Thunderbird* on Windows
  • Removed references to the standalone executable of the Windows script.

* Note that emails sent from Thunderbird don't include the From, To, Sent, or CC headers. Thunderbird (like Firefox) is not scriptable and those fields are not available. Only the body of the email or the selected text will be included in the task or note. Fortunately the email subject is available through some trickery and is used for the task or note name.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Location based reminders won't work Gurke OmniFocus for iPhone 2 2012-10-17 09:30 AM
Run Omni on Windows from Work, or any PC Mac OmniFocus 1 for Mac 0 2012-01-24 03:41 PM
Defining OmniFocus sub-contexts for computer-based work RobTrew OmniFocus 1 for Mac 0 2010-12-29 08:21 AM
Folks who work in PC-based environments, how do you apply Omnifocus? Mischka07 Applying OmniFocus 13 2010-06-03 09:50 AM
Omnifocus on Windows based PC NHenshaw OmniFocus 1 for Mac 1 2008-07-27 08:01 AM


All times are GMT -8. The time now is 07:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.