The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Omniweb Applescript Question Thread Tools Search this Thread Display Modes
Hello

Can someone please help me. The code below
works as it should, sort of, it creates the new
browser and loads the urls all right but it takes
place in the background ... how ֔$
do I programmatically activate the new browser
when the script has run ?? or even before

=====
property theUrls : {"http://members.easynews.com/global4/search.html",
"http://members.easynews.com/group.html?group=alt.binaries.e-book.technical",
"http://members.easynews.com/group.html?group=alt.binaries.mac.applications",
"http://members.easynews.com/group.html?group=alt.binaries.mac.osx.apps"}

tell application "OmniWeb"
set nyBrowser to make new browser at end of browsers with properties {address:"http://members.easynews.com/index.html?favorite=1"}
repeat with i from 1 to count of the theUrls
tell nyBrowser to make new tab at end of tabs with properties {address:item i of theUrls}
end repeat
end tell
=====

Regards
Russophile
 
Don't you just need to add "activate" before the "end tell"?
 
Quote:
Originally Posted by Handycam View Post
Don't you just need to add "activate" before the "end tell"?
No it doesn't work, and neither does eg. "tell nyBrowser to activate"

The new browser is created in and stays in the BG :(
 
You're telling the browser to be created at the very back of your browser windows with this line:

Code:
set nyBrowser to make new browser at end of browsers
Try using "beginning" instead of end.
 
Quote:
Originally Posted by troyb View Post
You're telling the browser to be created at the very back of your browser windows with this line:

Code:
set nyBrowser to make new browser at end of browsers
Try using "beginning" instead of end.
Indeed, that did it
thanks !
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
AppleScript question sputnik OmniFocus Extras 21 2009-11-02 01:47 PM
Applescript question for Omni Group pvonk OmniFocus 1 for Mac 3 2009-10-06 09:16 AM
new to OmniWeb - stupid question DrivinWest OmniWeb General 5 2007-04-12 11:43 PM
AppleScript broken in OmniWeb 5.5? vocaro OmniWeb Bug Reports 8 2006-06-08 09:18 AM
Omniweb and Applescript steve OmniWeb General 3 2006-05-16 05:40 PM


All times are GMT -8. The time now is 11:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.