The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > Developer > Omni Frameworks
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Xcode 4 Customized Build Location Thread Tools Search this Thread Display Modes
With the framework you are required to set a custom build location in Xcode 3.2.5. What is the equivalent setting for this in Xcode 4?
 
You no longer need to do this in Xcode 4; it automatically segregates build products from each workspace in ~/Library/Developer/Xcode/DerivedData. Instead, you need to make a workspace with the appropriate projects as members (along with your other app/framework targets).

If you are just checking out one of the iOS sample apps, you should be able to just open it and build (since those already have project references for the frameworks and Xcode 4 follows those).
__________________
CTO, The Omni Group
 
I'm getting multiple errors of missing files in even the example projects.

Is it neccesary to rebuild all the frameworks (using the script) now that I have Xcode 4 installed?
 
I'd recommend building with a workspace when using Xcode 4. Our internal build scripts minimally work with Xcode 4, but these simplified ones may need some extra help. By default Xcode 4 builds each workspace into its own built output directory that is intentionally segregated from all the others. This is possibly preventing the current github source from building.
__________________
CTO, The Omni Group
 
Hi,

As of now the application is creating in xcode installed directory but i wanted to generate where the source code folder is present

/Users/Test123/Library/Developer/Xcode/DerivedData/SampleApp-grvhozpetocxeydhunkerdavnvqm/Build/Products/Debug -- Here its creating

but i wanted to create in following path

/Users/Test123/SampleAppSourceCode/Builds/MacOS/Debug/

So please suggest where should i do modify this?

I am using xcode 4.0, earlier with xcode 3.x it was fine.

Thanks.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Build Framework Fails From Command Line But Build in XCode Succeeds davidbitton Omni Frameworks 2 2012-05-01 04:13 PM
Lion iOS 5 beta4 Xcode 4.2 build issues... SpiraMira Omni Frameworks 2 2011-08-29 02:31 AM
Xcode 4. jgarnham Omni Frameworks 7 2011-05-24 08:25 PM
Use same customized colors on iphone and mac mickh OmniFocus for iPhone 3 2009-11-30 03:55 PM
Customized sync mkko OmniFocus Extras 3 2008-02-23 12:34 PM


All times are GMT -8. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.