The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniFocus 1.8 restores only 1 window at relaunch Thread Tools Search this Thread Display Modes
In days past, OmniFocus typically opened only one Browser window at launch, regardless of the windows open Browsers at the most recent Quit. I was pleased when some OmniFocus release began restoring the size & position my two standard windows at launch.

After restarting Mac OS X 10.6.4 (which shutdown OmniFocus), I just launched OmniFocus 1.8. Only the most recent Browser window opened. Sigh.

-- Ward

[submitted as formal feedback]
 
Hmm. I certainly believe you, but when I just opened two OmniFocus document windows in 1.8, quit, and relaunched, they both showed up again. I wonder what's different?
 
I've usually got several windows open, and also do not recall seeing the behavior Ward reported. Sometimes it takes an unusually long time to draw the 2nd, 3rd, etc. windows after the first appears...
 
I just did the same: opened my standard 2nd window, Quit, and relaunched. Both windows reappeared with correct size and position.

I didn't try a Restart because it takes a while to shutdown and relaunch a bunch of menu extras and standard apps. When I'm not pressed for time, I'll see if Restart has anything to do with the missing window.

Before opening this thread, OmniFocus sat for 10-15 minutes after Restart, and the missing window did not appear.

This may be one for the "How about that!" bug pile. It's not a big deal. I just opened this thread in case others are seeing this small regression.

-- Ward

Last edited by Ward; 2010-09-19 at 07:43 PM.. Reason: add info
 
I've noticed this behavior under MacOS 10.7.5 and OF 1.10.4. The issue only happens on the machine with 10.7.5 (a separate iMac running 10.8 does not manifest the issue).

Product: OmniFocus-1.10.x
Tag: OmniFocus/1.10.4/GM-v77.90.20
Date: 2012-10-18 14:36:55 -0700
Builder: omnibuild
Host: tb106a.private.omnigroup.com
Revision: 174315

I tried changing the settings of what perspective to use with new windows but no luck. OF always brings up just one window.

Any ideas how to fix this?
 
Try unchecking "Close windows when quitting an application" in the General section of System Preferences. OmniFocus should then be able to restore the window layout from your last session.
 
Quote:
Originally Posted by schenk View Post
Try unchecking "Close windows when quitting an application" in the General section of System Preferences. OmniFocus should then be able to restore the window layout from your last session.
That was the issue.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Open OmniFocus links in the same window? JustinLuey OmniFocus 1 for Mac 0 2012-06-25 05:20 PM
Growl opens new OmniFocus window adhamh OmniFocus 1 for Mac 7 2008-04-14 05:51 PM
Bug: "cleaned-up" inbox items reappear on relaunch jrk OmniFocus 1 for Mac 22 2007-10-01 11:51 PM
Force Quit + relaunch opened wrong workspace kballard OmniWeb Bug Reports 2 2006-05-12 02:38 PM
sp3 not reloading tabs on relaunch? j.a.duke OmniWeb Bug Reports 6 2006-05-03 08:54 AM


All times are GMT -8. The time now is 11:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.