The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Open "New Window" in New Tab? Thread Tools Search this Thread Display Modes
Hey there,

Quick question...

I used to set my Saft settings so that whenever ANY link which would open in a new window was clicked, it would open it in a tab in that same window.

I can't find this setting at all in Omniweb. I'm on a laptop and I don't always use a mouse, so command-clicking is sometimes just...clunky. Is there a way to do this without having to middle-click/command-click a link? Any info would be appreciated. :)

Thanks.
 
There is a hidden preference that will force links that try to open in a new window to open in a new tab instead.

Copy this and paste it into a Terminal window if you want to try it out.

Code:
defaults write com.omnigroup.OmniWeb5 OWOpenNewFramesInTabs -bool true
This is an experimental setting, which is probably why you can't toggle it on/off in the preferences yet. I found it not to my liking, as it also opens all JavaScript "window.open" windows in tabs, and usually that's not what I want (most of the time those are small windows used to do things like view the full size version of an image, or display a little dialog, or something like that).

If there was a way to only catch regular <a href="..." target="blank"> links, I'd definitely use this feature. But give it a whirl, maybe you'll like it. If not, paste the same command into Terminal, but change "true" to "false" to turn it off again.
 
Thanks. I'll give it a try.

Very much appreciated.
 
FWIW, this has been a very much requested feature by many, many people to be added to OmniWeb during the 5.5 sneakypeek and beta development period. I suspect (or is that hope! :p ) it is probably one of the priorities once 5.5 final is released.
 
Yeah, this is a feature of SafariStand that I used and absolutley LOVED.

9 times out of 10, I only want 1 browser window open. If I want another window open, I'll open it myself.

To Stormchild > I found the workaround for that is that if you know a new window wants to open with it's own size, etc.., then you can just right click and say open in a new window. I found this occasion so rare compared to occasions when normal links would open in new windows that it was the perfect behavior for me.

It'd be great if this was a preference.

Cheers
 
FWIW, I noticed IE7 does this. And it's a complete PITA, IMHO. For example, on the Amex travel site, clicking on the date input field opens a popup to select the date on a calendar. Rather than opening a small pop-up where I click on the right date and the window automatically closes, it opens a whole new tab, in the background, which I have to switch to to select the date.

So if OW copies IE, I really hope it's made as a preference I can disable.
 
Agreed.

I hope that whatever pref is added will differentiate between target=_blank and javascript popups.

Javascript popups, like Forrest describes, I ALWAYS want in a new window, correctly sized as the web site intended.

It's those annoying target blank pages that I want trapped into a new tab instead. Firefox (optionally) can do this.
 
defaults write com.omnigroup.OmniWeb5 OWOpenNewFramesInTabs -bool true

This does NOT work in the way I was asking and was linked to this thread. This hidden pref opens EVERY link in a new Tab. I only want links that DONT open in the same Tab to spawn a new Tab, in fact id prefer a setting that forces all these stupid "open in new window links to open in the SAME Tab/Window, if i wanted the link to open in a new Tab/Windows i should have the option to use Command+Click.

It just doesn't make sense in the context of forums, you read the first thread in a forum it may have a link, I don't want it to open a new window/tab to view later because the very next message in the forum thread will be discussing the contents in the link. I ideally i want to click the link in the same window/tab to view it, then go use back button an comment or read what others have commented about it. If i wanted to compare the linked window with another window then sure command+click it to spawn a new tab/window.

OW provides the option to force "open link in new window" links to open in a new Tab which I want but its BROKEN. I just wish robots like "Forest" would stop getting sherty with us bringing this issue up an dismissing us and providing useless inappropriate comments and suggestions such as links to this thread which deals with a completely different issue.

Sorry for bitching, im just sick of having my time wasted trying all these useless work arounds when i know what im talking about doesn't work and i have to waste time re-iterating what was clearly mentioned in the first place.

Sorry Forest for singling you out, i know you was trying to be helpful. I don't mean to lash out. consider it my frustration.

Last edited by Drayon; 2006-09-08 at 07:09 PM..
 
Quote:
Originally Posted by Drayon
defaults write com.omnigroup.OmniWeb5 OWOpenNewFramesInTabs -bool true

This does NOT work in the way I was asking and was linked to this thread.
Interesting. I just went back and read your post again. I then went through the steps posted here (and elsewhere in this forum regarding this issue) and it works just like you were requesting. It sounds like you may have some other settings which are interfering with this. Also note that this is a hidden pref for a reason:

Quote:
Originally Posted by Len Case
There is an experimental hidden default (the mis-named OWOpenNewFramesInTabs) which should catch both window.open and target=_blank and make new tabs instead.
Code:
defaults write com.omnigroup.OmniWeb5 OWOpenNewFramesInTabs -bool true
This is not a public feature yet since all the bugs haven't been worked out. For instance it bypasses the popup-trap (if you use that option) and it may have other problems.
Quote:
I just wish robots like "Forest" would stop getting sherty with us bringing this issue up an dismissing us and providing useless inappropriate comments and suggestions such as links to this thread which deals with a completely different issue.
Well, this setting works well for myself, and for many. No, it's not perfect, but it's perfectly useful and appropriate for the issue you're trying to solve. If you just want to send in bug reports and aren't asking for support or feedback from the forum users, just use the "Help> Send Feedback..." option from within OW.

Quote:
Sorry for bitching
Judging by results, and that being personal attacks, you're not sorry.

Quote:
im just sick of having my time wasted trying all these useless work arounds when i know what im talking about doesn't work and i have to waste time re-iterating what was clearly mentioned in the first place.
There are several other threads on this. I have used this forum since its inception, so I have a bit of a memory as to what's here and what to search for. As a result, I know that in the other threads this has been mentioned (and search for "OWOpenNewFramesInTabs" to find them) the pattern has been that what you're asking for, is what this does... albeit with some quirks. I'm not expecting you to know all that, though it'd be nice if you searched a little more (but it seems you're strapped for time, just trying to find something that works without having to learn all about it, and I can understand that as well.)

I too find this feature a bit irritating. This and a few other issues have sent me back to 5.1.3 (that's what I'm posting with) until the 5.5.1 sp's come out.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Import error: OmniGraffle Pro cannot open files in the "XML text" format MCV OmniGraffle General 5 2012-08-31 11:43 AM
Disable "double click on a tab preview to open in a new window" dangerous OmniWeb Feature Requests 2 2007-08-22 05:33 PM
"Open" command in downloads window syoutsey OmniWeb Feature Requests 2 2007-07-03 02:28 PM


All times are GMT -8. The time now is 05:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.