The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Web Interface Port Change Thread Tools Search this Thread Display Modes
Is there any way to change the default port of the OF Web Interface from 3000?

I have lots of things set up based on Ruby on Rails dev sites running on that port, and I don't like the idea of having to change all of that just to run OF Web.

Also, does the use of the port 3000 have anything to do with using rails behind the scenes to generate the web interface? I was thinking about doing that in an app I'm working on ;)

Regards,
Alex Speller
 
I don't think there's a way to change the port. I looked through all the text files I could find in the .app to see if I could change it by editing one of them and didn't find any.

I believe that Rails is being used:

/Applications/OmniFocus.app/Contents/Resources/rails
 
when I launched the web interface and went to Terminal and ran 'ps' I saw:

/usr/bin/ruby ~/Library/Application Support/OmniFocus/Web Interface/script/server webrick -e production
 
Heh heh, rails is getting everywhere these days. Looks like my crazy scheme for my project isn't so crazy after all. Thanks for poking :)
 
Quote:
Originally Posted by alexspeller
Is there any way to change the default port of the OF Web Interface from 3000?
The MOTD from OmniFocus-r89114-Alpha.dmg reports:

July 23
Added a hidden preference 'WebInterfacePort' defaulting to 11872. This will avoid using the default Ruby on Rails port 3000, which several testers are using for their own RoR projects.
 
I can't connect with 11872. 3000 doesn't work either, of course.

Is there a server that should show in Activity Monitor? When I close OF, then try to view in OmniWeb, OF doesn't start like it did when using 3000.

Doesn't work locally or via the Internet.
 
Quote:
Originally Posted by Terry
I can't connect with 11872. 3000 doesn't work either, of course.
Sorry, I have to ask... did you double check to make sure that it is turned on in OF preferences?

Quote:
Originally Posted by Terry
Is there a server that should show in Activity Monitor? When I close OF, then try to view in OmniWeb, OF doesn't start like it did when using 3000.

Doesn't work locally or via the Internet.
are you trying localhost:11872 or 127.0.0.1:11872 or ?

The only thing I see in activity viewer is 'ruby' when it's running... of course that might be something else if you have other ruby apps running.

Best thing to do is to launch Terminal.app and type (or copy/paste) this:

ps auxww|fgrep -i omnifocus | sed G

which should give you something like this:

tjl 22831 0.8 -1.0 46216 20956 ?? Ss 12:18AM 0:02.78 /usr/bin/ruby /Users/tjl/Library/Application Support/OmniFocus/Web Interface/script/server webrick -e production --port 11872

(note: you can pretty much ignore everything before the /usr/bin/ruby on each line above, as they will change. The point is that you should see the ruby line above if it is running, even if OmniFocus.app is not)
 
Quote:
Originally Posted by luomat
Sorry, I have to ask... did you double check to make sure that it is turned on in OF preferences?
Yes, in fact I stopped it and restarted the server in case that was necessary.


Quote:
are you trying localhost:11872 or 127.0.0.1:11872 or ?
Locally I'm actually using 192.168.1.10:11872;

Via the Internet I was using no-ip.

Both worked very well before the port change from 3000. When 11872 was incorporated, nothing worked anymore. Yes, I had changed my Linksys port forwarding.

=-=-=-=--=-=-=-=-=-=-=--=-=-=-=-=-=-=-=

I answered the above question in case I was still doing it wrong. I'm definitely no expert at doing this stuff, but the basics are simple enough.

Anyway, I'm constantly getting the latest sneaky peek, and perhaps the ninjas found something because of my feedback.

I just tried Web access and it's working wonderfully. I haven't changed anything since my original post.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alternate port for WebDAV dmarkow Other WebDAV 1 2008-07-18 01:56 PM
Web Interface Port # Question kingsinger OmniFocus 1 for Mac 0 2007-09-13 04:37 PM
Change in OF Scripting Interface curt.clifton OmniFocus Extras 4 2007-09-06 06:35 PM
port forwarding (Lighthouse)? zxspectrum OmniFocus 1 for Mac 0 2007-07-30 04:36 PM


All times are GMT -8. The time now is 03:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.