The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 3 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

$9900 problem in currency column formats Thread Tools Search this Thread Display Modes
I am trying to create a simple column to add numbers with dollar figures. When I have it formatted with just decimals (9999.99) it works fine. When I format the column with dollar signs as I want it ($9999.99) it adds $9900 to whatever figure is in the cell. So if I enter 42.50, when I leave the cell it reads $9942.50.

Actually when I tried using some larger numbers it just adds a nine to whatever is missing, so $780 becomes $9780.

What is going on with that? Is there a fix?

I tried throwing out permissions, logging out and starting again. Same deal. None of the other number options have the problem—only the one with the dollar sign.

Any help appreciated.

Last edited by MichaelG; 2008-06-02 at 09:47 PM.. Reason: more details
I believe you, and this is clearly a bug, but I can't seem to reproduce it here: for me, entering a value of "12" gives me a result of "$12.00". (And just to be certain, I tried your examples of 42.50 and 780 and got back "$42.50" and "$780.00".)

It might have something to do with your Currency format settings in System Preferences (under International / Formats): mine is currently set to "US Dollar". Or perhaps it's related to something else in your environment.

My advice would be to send feedback to Omni's technical support ninjas by selecting Send Feedback from the Help menu (or just sending email to hopefully they'll be able to help you diagnose and work around the problem. (And if they can figure out how to reproduce the bug here, it will make it much easier to track down and fix for a future release.)

Hi Ken, Thanks for your reply. I appreciate it. Unfortunately it is not the system preferences currency setting. That was set to US dollars. I changed it and changed it back to see if it made any difference. No luck. I've tried several different values in the OO cell and always get the same pattern. I did send it off to the support ninjas as you suggested. I'm bummed. OO would have been perfect for what I wanted to use it for.

Here's hoping on a fix. Thanks again,

I know we ran into this problem before with a customer a couple of months back. We solved it, but I can't remember the details.

I'll go spelunking in our trouble ticket system to see if I can locate the ticket again. If I remember correctly, it did end up being a system preference, but it was some odd one - not the ones that the System Preferences pane touched.

More info as I find it...
Okay, for future reference, found the info.

Last time someone had this behavior, they had a couple of defaults options set which specifically override whatever behavior the System Preferences pane had specified. OmniOutliner is dutifully respecting those defaults commands.

Specifically, they had these settings active:

NSNegativeCurrencyFormatString = "-$9,999.00";
NSPositiveCurrencyFormatString = "$9,999.00";

If you want to remove those settings, you can do so with the following steps:

Open the Terminal application (from your Utilities folder).
Enter each of the following two commands - you want everything between the quotes, but not the quotes. Hit Return after each command.

"defaults remove NSGlobalDomain NSNegativeCurrencyFormatString"
"defaults remove NSGlobalDomain NSPositiveCurrencyFormatString"

Once you do that, OmniOutliner should behave as expected; you may need to relaunch it if you had it running when you entered the terminal commands.

Let me know if you have any questions about this!

Last edited by Brian; 2008-06-03 at 01:58 PM.. Reason: I can not spell.
Edited the title of the thread to hopefully make it easier to find when/if folks search on this problem in the future.
Hey Brian. That did it!

Two quick questions:

Any ideas what creates that setting in the first place? and Any chance that changing that would affect any other programs/functions adversely?

I really appreciate your help. Great to have it working.

Thank you,

We're not sure how it got set - the other person that had this problem was actually british, so it was even weirder that it was set.

The default state of the system as we understand it is to not have that setting there at all; that means 'just use the system preferences setting'. So the commands I suggested are basically just restoring the intended status quo.

However, if some application set that, or is dependent on having that setting set a particular way, it'll now probably be a bit confused. Since we didn't write the app, or know what got the setting that way, we can't predict much more than that.

One thing you could try would be to run these two commands, which restore those defaults settings, but with a slightly different behavior. (The '#' character, in this context, means 'any digit can optionally go here'.)

defaults write NSGlobalDomain NSPositiveCurrencyFormatString '$####.##'
defaults write NSGlobalDomain NSNegativeCurrencyFormatString '$####.##'

A specific number means 'if I don't type a number in this spot, add it for me', which is why you were getting what you saw before.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
OO Column Formats - IP (and MAC) Addresses? pnm OmniOutliner 3 for Mac 0 2012-01-30 12:48 AM
Custom Currency Number style vicberger OmniOutliner for iPad 1 2011-05-13 01:35 PM
Currency units for resources Mr Paterson OmniPlan General 3 2010-03-08 02:50 AM
Problem with popup column davidinva OmniOutliner 3 for Mac 2 2009-09-24 06:25 AM

All times are GMT -8. The time now is 06:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.