The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > Applying OmniFocus
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Unable to create local socket Thread Tools Search this Thread Display Modes

I have updated OmniFocus from 1.5 to 1.7.5

I have the iPhone version 1.5.3 and I am running SnowLeopard 10.6.2

I had absolutely no problem with version 1.5

Now, Omnifocus is not usable anymore. Every time i launch it, i have an error message "Unable to create local socket" and impossible to synch with the iPhone. The firewall is off. And same problem if i connect directly wifi between the Mac and the iphone ...
Fortunately, before upgrading I made a backup of the working version 1.5 and when i revert, the problem is gone and everything works back like before.

27/12/09 14:51:53	GrowlHelperApp[215]	Auto-discovered registration ticket in OmniFocus (located at /Applications/
27/12/09 14:51:53	OmniFocus[19644]	Presenting modal error: {
    code = 2143;
    domain = "com.omnigroup.OmniFocus";
    userInfo =     {
        NSLocalizedDescription = "Impossible de lancer le serveur de synchronisation.";
        NSLocalizedRecoverySuggestion = "Unable to create local socket";
        NSUnderlyingError =         {
            code = 48;
            domain = "com.omnigroup.OmniFocus.XMLData.ErrorDomain";
            userInfo =             {
                NSLocalizedDescription = "Impossible de cr\U00e9er une interface de connexion.";
                NSLocalizedRecoverySuggestion = "Unable to bind socket.";
                NSUnderlyingError =                 {
                    code = 48;
                    domain = NSPOSIXErrorDomain;
                    userInfo =                     {
                        NSLocalizedDescription = "Unable to bind socket.";
                        NSLocalizedFailureReason = "bind: : Address already in use";
                "com.omnigroup.framework.OmniBase.ErrorDomain.FileLineAndNumber" = "/Volumes/Local/Users/Shared/kc/ReleaseProduct/Source/OmniGroup/Applications/Focus/XMLData/XMLSyncServiceRegistration.m:49";
        "com.omnigroup.framework.OmniBase.ErrorDomain.FileLineAndNumber" = "/Volumes/Local/Users/Shared/kc/ReleaseProduct/Source/OmniGroup/Applications/Focus/App/HTTPServer.m:381";
27/12/09 14:52:00	SystemUIServer[170]	__CFServiceControllerBeginPBSLoadForLocalizations timed out while talking to pbs
27/12/09 14:52:00	OmniFocus[19644]	__CFServiceControllerBeginPBSLoadForLocalizations timed out while talking to pbs
27/12/09 14:52:03	mDNSResponder[18]	ERROR: handle_regservice_request - name bad 330532:19644:aaaa@aaa-MacBook-Pro.local

Last edited by Jack75; 2010-08-13 at 04:04 AM.. Reason: removing personal information
You'll get faster technical help by using Help → Send Feedback to send requests directly to Omni.

That said, have you tried rebooting before launching OF 1.7.5? Reading the log you posted, it appears that there is already a server running at the same address that OF wants to use. I wonder if that might be the OF 1.5 server. Rebooting would make sure the old one (or any other one that wasn't auto-launched) was shut down.



Yes i did reboot. In fact i did it before posting the message and after I made the log.
But after my reboot, i had still the same error message ! ??

So that's why I posted my message int this list with the log i made and everything I got.
Sounds like you did the right thing.

As I said, use Help → Send Feedback to email the OmniGroup for help on this one.




Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to create single task in folder Tado OmniFocus 1 for Mac 3 2012-03-19 06:52 AM
local syncing? gravescp OmniFocus Syncing 1 2008-08-27 12:04 PM
Unable to create XML archive otter OmniFocus Syncing 0 2008-07-14 09:02 PM
'Unable to create configuration folder' error kliere OmniWeb Bug Reports 1 2007-11-02 12:31 AM

All times are GMT -8. The time now is 09:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.