The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Text Encodings menu NOT checked-how it works or is it bugged out? Thread Tools Search this Thread Display Modes
Hi,

In the View Menu -> Text Encoding

If i select and encoding such as Unicode UTF-8 or another one there is no TICK to display this encoding is being used. Further, if i select Use Character Set Provided by Server from this same menu, again, this item is NOT checked with w TICK to signify that this is the setting enabled. Other browsers use a check to display the item enabled but not in this case in OW. Is this a Bug because other menus in OW have a TICK check next to items such as the selected Workspace.?

This wouldn't usually be such an issue (even tho some pages display some strange characters at times) BUT in a particularly critical situation today I noticed a peculiarity in my router. I was setting the Wireless WPA-PSK and the option listed some invalid characters not to be used for the passphrase. This became confusing because these were actually different characters to what was displayed in other browsers. I had the main Language preference in OW Assume pages use text encoding set to UTF-8 and this was different to browsers set to ISO Latin 1 hence the different display of characters (no wonder why Airport was and my router was rejecting my passphrases).

Safari preference has a Default Encoding which the user can set globally which i assume the view menu allows a different encoding based on individual pages yet there is no Use Character Set Provided by Server
setting in Safari like OW.

Im curious to know if this Use Character Set Provided by Server setting in the View menu in OW when clicked on is actually functional considering there is no actual visible way of knowing the feature is enabled.

BTW what is the most preferable Text Encoding i should use? Considering my OS install is US English (even tho im in Australia i prefer US English to British/Australian english).

Ideas thanks
 
Safari:
Default is to use the character set provided by server, if there's none set in the meta tags, it will use the default set in your preferences. As soon as you manually set another encoding, it will override either.

OmniWeb:
Default is to use the character set provided by server, if there's none set then use the one set in Language Preferences. Manual selection of a character set overrides either.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where do checked items go? michael.prescott OmniFocus 1 for Mac 1 2009-08-27 08:13 AM
Bugged out-OW looping to death. Drayon OmniWeb Bug Reports 0 2007-06-25 03:50 AM
Checked row colours slithytove OmniOutliner 3 for Mac 1 2006-12-04 10:39 AM
Bookmarks checked for changes too often vocaro OmniWeb Bug Reports 1 2006-07-29 12:39 AM


All times are GMT -8. The time now is 02:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.