The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Maintaining orthogonality of lines Thread Tools Search this Thread Display Modes
I am using OmniGraffle for drawing circuit diagrams. I have learned that one must place the components in their approximate locations and then connect them with lines. The problem is that the lines are either skewed (if I use straight lines) since the parts are not exactly positioned or there are unsightly "switch-backs" if I use the orthogonal line tool. I considered using the grid, but that is a little confining. Things would work fine if one could re-position the parts holding down the shift key to make all the lines horizontal or vertical. This works after a fashion - the line is nicely locked in orientation until the end intersects another line, at which time the lock is lost. Does anyone have any ideas of how I can do this?

Thanks.

Warren Nagourney
 
I always use the grid (and snap-to-grid), but you might try the following, not sure if it's what you want. Select the shapes and then choose the alignment tool of the canvas inspector and use that to align the objects horizontally or vertically.

I'm not sure how you work in OG, but I can't do anything without having both the inspector and the stencil window open at all times.
 
Thanks again, Chris. Yes, I always keep the stencil and inspector windows open. The former is due to an excellent suggestion from Joel from Omni: the way to get the effect of a favorites menu item in standard OG is to have all of the shapes and lines of interest in an open stencil.

I tried using the grid and avoiding magnets. One of the problems with this is that connections always go to the middle of a shape. Therefore, if you have, say an op-amp, the inputs go to the middle, which of course is not what you want (there are two input pins). How do you avoid this?

Another problem with the grid is that your stencil items need to take account of it. Many of the things from Graffletopia do not (again, the op-amp in the electronics stencil does not). You need to make a completely new specialized stencil, it would seem. Is there a way around all of this?

Cheers,

Warren Nagourney
 
Ah, I see the problem and what you want to do. I've only made circuit diagrams for first-year physics classes, so I hadn't confronted this. I assume you've been using the electronics stencils that are built in? The op-amp there has exactly the problems you mention.

I don't know how to solve this along the lines of your current workflow.

The way I would do it (in fact the way I have done it), is to turn off all connections and use the grid. I made all my own stencils for circuits, so I don't use any of the built-in ones. They are all sized the way I want them, so that's nice. So if I needed an op-amp, I would create a stencil that was appropriately sized and that put the connections on the grid right where they should be.

It's quite possible that my workflow won't scale well to complex diagrams, and it's fragile in the sense that making substantive can be a pain because each component needs to be arranged separately. It also doesn't make use of some of the neat things OG tries to offer, but I haven't gotten those things to work for me in this context. On the other hand, it does take advantage of some of the other feature of OG, like the ability to make new shapes and the ability to save things as stencils. Compared to what I once used (xfig) it's a big win.
 
Yes, that is what I thought. Using magnets works pretty well and avoids this problem. One can take the stencil items and place the magnets wherever one wants and the lines snap to the magnets (and the connections are preserved when you move the objects, which is nice). For the op-amp, the magnets are at the two inputs and one output (assuming you are not showing power connections).

With this approach, the problem is to make the drawing look decent - all the connections are there (permanently) but the lines can often look very weird. OG has its own ideas about how lines should be placed and these are hard to override. The closest to what I want comes when I use the orthogonal line tool - at least the lines are always horizontal or vertical. Then items can be moved to get rid of the unnecessary "switch-backs".

Cheers,

wn
 
Chris,

I have just been playing around with the approach I mentioned in my last post and I am getting to like it for circuit drawing. When one moves items to get rid of what I called "switch-backs", I just discovered that one can hold down the command key to turn off the guides, which are often helpful but sometimes not. Again, the permanent attachment of the wires makes it very easy to re-arrange parts. This latter feature is a great advantage of OG over plain CAD programs (though electronic design CAD programs probably have the feature).

Cheers,

wn
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suggestions for Maintaining Balance AND Getting Things Done bmushrush Applying OmniFocus 6 2012-10-12 01:21 PM
Problems Maintaining a Focus When Moving from Context to Planning Mode usertech OmniFocus 1 for Mac 2 2012-06-05 01:58 AM
Maintaining linked images on network volumes Andrew N OmniGraffle General 4 2012-01-26 04:14 AM
Tables with Horizontal Lines (but not Vertical Lines)? lanceosborne OmniGraffle General 6 2010-11-11 01:40 AM
Maintaining keyboard focus vamp07 OmniWeb General 2 2006-08-26 07:35 AM


All times are GMT -8. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.