The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OS 10.6 - Clipping Shortcut problems [Thread Deprecated] Thread Tools Search this Thread Display Modes
It sounds like Tom is seing something slightly different than I am on my 10.6 machine - not sure why that is, so if he could please email the support ninjas, we'd love to investigate this.

Just in case other confused folks land in the thread, though, and at risk of stating the obvious, I belive Snow Leopard turns all keyboard shortcuts assigned to services off by default.

If folks open the Keyboard pane of System Preferences, select "Services" in the sidebar, and check the "Text" section of the services list, does "OmniFocus: Send to Inbox" have a checkbox next to it?

The list isn't alphabetical, so you may have to scroll around a bit to find it.

Last edited by Brian; 2009-08-28 at 04:06 PM.. Reason: email link for Tom.
 
Brian,
I have emailed the ninja's. Just to clarify, I do see the text entry for Omnifocus:Send to Inbox in services and it works. The application shortcut Omnifocus: Send to Inbox is set with F12 but no box to enable it. Is that normal behavior? I get a growl helper attempt to pop autorelease pool in the console when trying to use the F12 (not consistently though) and it just beeps. Hope that helps.
 
I just reported this to the ninjas.

"Incompatible Plug-ins Disabled

Mail has disabled the following plug-ins:

OmniMailMessageServiceEnabler

Contact the makers of these plug-ins for versions that are compatible with Mail 4.0 and Message 4.0."
 
I got the Send to OmniFocus Mail Rule working now, and told the ninjas.

I recreated the rule.

I just realized I've been posting in a thread about a different thing (clipotron). Sorry, in all the confusion, I kinda lost track.

Bob
 
So after choosing to install the Clip-O-Tron 3000 under OF v1.7.1, it doesn't work. It's not even in /Library/Mail/Bundles or Bundles (Disabled). Checked the console and see the following:

8/28/09 8:24:08 PM OmniFocus[926] Failed to install '/Users/jrogers/Library/Mail/Bundles/OmniMailMessageServiceEnabler_106.mailbundle' from '/Applications/OmniFocus.app/Contents/Resources/OmniMailMessageServiceEnabler_106.mailbundle'

What to do here? I guess I'll manually copy the file...

UPDATE: After manually copying the file, it still doesn't work... guess i'll try repairing permissions with Disk Utility...

Last edited by KG6BGJ; 2009-08-28 at 07:48 PM..
 
Quote:
Originally Posted by tom.mancino View Post
Brian,
I have emailed the ninja's. Just to clarify, I do see the text entry for Omnifocus:Send to Inbox in services and it works. The application shortcut Omnifocus: Send to Inbox is set with F12 but no box to enable it. Is that normal behavior? I get a growl helper attempt to pop autorelease pool in the console when trying to use the F12 (not consistently though) and it just beeps. Hope that helps.
Try looking with Services selected in the sidebar, and scroll down to the "Text" grouping.
 
I'm getting the same console message after installing the clip-o-tron:

8/29/09 8:22:48 AM OmniFocus[441] Failed to install '/Users/snpower/Library/Mail/Bundles/OmniMailMessageServiceEnabler_106.mailbundle' from '/Applications/OmniFocus.app/Contents/Resources/OmniMailMessageServiceEnabler_106.mailbundle'
 
I still get this same message.

Failed to install '/Users/snpower/Library/Mail/Bundles/OmniMailMessageServiceEnabler_106.mailbundle' from '/Applications/OmniFocus.app/Contents/Resources/OmniMailMessageServiceEnabler_106.mailbundle'

However it does appear in the Mail/Bundels folder. As far as I can tell the service works, just not the application shortcut that is tied to my hotkey F12. I can't seem to add a shortcut to the service in the system pref pane - even though it appears when I righ tclick on an email as Omnifocus:Send to Inbox F12. It does appear in application shortcut, and I think this might be the expected behavior? Very weird.

Last edited by tom.mancino; 2009-08-30 at 05:11 AM..
 
Quote:
Originally Posted by xmas View Post
Try looking with Services selected in the sidebar, and scroll down to the "Text" grouping.
This is not an issue. It is enabled in services and applications.
 
Quote:
Originally Posted by tom.mancino View Post
However it does appear in the Mail/Bundels folder. As far as I can tell the service works, just not the application shortcut that is tied to my hotkey F12. I can't seem to add a shortcut to the service in the system pref pane - even though it appears when I righ tclick on an email as Omnifocus:Send to Inbox F12. Very weird.
Same issue here on new Snow Leopard installation. Clipping services works, but application shortcut does not. Solved by opening preferences in OmiFocus and choosing clippings shortcut again. To be clear, the clipping shortcut indicates the selected key is set - it just doesn't work in mail.

Click in the clipping shortcut selection box and press the key of choice (even the same key as before). Voila, all works again.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't set clipping shortcut tedhogan OmniFocus 1 for Mac 8 2011-08-29 03:33 PM
Can't assign clipping shortcut mitchellzone OmniFocus 1 for Mac 28 2011-05-02 09:56 PM
No clipping shortcut possible mkurz OmniFocus 1 for Mac 1 2010-06-14 01:20 PM
Clipping problems in 10.6 mmurray OmniFocus 1 for Mac 7 2009-10-19 12:08 AM
Clipping Shortcut not working gryphonent OmniFocus 1 for Mac 12 2008-06-06 02:10 PM


All times are GMT -8. The time now is 04:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.