The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Populate Template Placeholders, 0.6.1 Thread Tools Search this Thread Display Modes
Henri, the middle section of the following code fragment shows how you can set those values.

Code:
tell application "OmniFocus"
	tell front document
		tell document window 1
			set theSelectedItems to selected trees of content
			set selectedItem to value of item 1 of theSelectedItems


			-- set next review date to tomorrow
			set next review date of selectedItem to (current date) + (1 * days)
			-- set review interval to 3 weeks
			set reviewInterval to {fixed:true, unit:week, steps:3}
			set review interval of selectedItem to reviewInterval


		end tell
	end tell
end tell
 
Awesome! Thank you.

--Henri
 
Question everyone ...

I followed the instructions, and I can get it to duplicate a project, but it isn't replacing the placeholder text nor changing the date for me. I am getting the prompt for the new "Due Date" and for the "ClientName" (what my placeholder text is), but it won't fill it in for me.

Any ideas?
 
Can you post a screenshot of your template, making sure to show the notes field for the template and the start and due date columns?

If you don't spell the placeholder exactly the same in the notes field and where you use it, no substitution will be made, and no warning given.

Did you heed the following line in the instructions?

Note, the project must have a start or due date (or both) or the script will not set dates on the actions.
 
If you already have a list you have been using in a text document Rob Trew's script is a nice quick start to transferring the info to OmniFocus through cut and paste.

http://forums.omnigroup.com/showthread.php?t=4883

Great script Curt, I finally got around to using this to set up some templates. Thanks for the screen shot in your instructions, I didn't realize you could put comments on a project but makes sense.

By the way from the instructions it mentions
"With OmniFocus running, hold down the Option key and select the Populate Template Placeholders script from the script menu. The script should open in Script Editor."

This didn't work for me did OmniFocus get rid of this feature?
 
Still works for me in 10.6.8 with OF 1.9.3.
 
Thanks whpalmer4, that is the same set up I have on my systems, I tried this on three computers as well and closed ever background and foreground app I had open and it still didn't work for me. Strange, I am clicking an script in the toolbar while holding down option and it just runs the script.

Others strange things on one of my home computer it doesn't let me use one of my key commands for a perspective. I have checked my system keyboard shortcuts and nothing uses it and no other app or background app is open that I know of. I wish I could get the ghost out and knew of a way to track things like that down, because that doesn't make sense.
 
Quote:
Originally Posted by skillet View Post
I am clicking an script in the toolbar while holding down option and it just runs the script.
There's your problem, this works when you select the script from the Script menu, not the toolbar. The devil's in the details :-)
 
Quote:
Originally Posted by whpalmer4 View Post
There's your problem, this works when you select the script from the Script menu, not the toolbar. The devil's in the details :-)

Thanks Bill, I figured it was something silly, I completely forgot that the applications scripts now show up in the scripts menu (I've had that set up for a couple years now). I was remembering the old way where it would show up next to the App menus at the far right if you had added any for a particular app.

Just a reference for anyone else that has my problem see post one.
http://forums.omnigroup.com/showthread.php?t=7453
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Populate Template Placeholders script Not filling placeholders Tim1 OmniFocus 1 for Mac 2 2013-03-11 03:32 PM
Adding Due and Start Dates for Populate Template Placeholders jessicatmt OmniFocus Extras 1 2012-08-06 10:05 PM
'Populate Template Placeholders' could not complete. Solana OmniFocus 1 for Mac 5 2012-03-21 09:53 AM
Curt Clifton's Populate Template Placeholders bcap OmniFocus Extras 1 2011-02-17 09:31 PM
Populate Template Placeholders Script problem Danoz OmniFocus Extras 8 2007-09-11 03:34 AM


All times are GMT -8. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.