The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Total data loss after sync... Thread Tools Search this Thread Display Modes
Hmm. Well I've just done a sync and just about everything in my OF library (except the contents of the inbox) has disappeared.

No problem I though, I'll just revert to a backup. I went to do so and found that the Omnifocus Backups folder is EMPTY, even though it's set to backup twice a day. There are a bunch of backups in the trash but it doesn't seem to be able to restore from any of those either (and they seem suspiciously small too..)

Oops!

Next problem, as soon as I tried to restore, it updates the version on my iDisk and so it's now overwritten what was presumably a valid version

Double oops!

Looking back via Time Machine it seems the last backup available was 21st June. Presumably about the time I started using the sneaky peaks again?

The version on my Touch is still valid at the moment, anything I can do to restore the desktop from that without reverting to a two-week old backup from the old database?
 
Luckily enough, I found all the backup documents - in the trash!

It seems OF had been prematurely retiring the backups - instantly.

Anyway, zapping the database and restoring from last nights backup and I'm now back up and running. It remains to be seen what happens next time I sync.
 
Check your backup location in OF. Make sure it's not set to a folder that's been deleted or something.

Do a manual test backup -- I suspect there's something strange in your setup somehow.
 
Quote:
Originally Posted by CatOne View Post
Check your backup location in OF. Make sure it's not set to a folder that's been deleted or something.

Do a manual test backup -- I suspect there's something strange in your setup somehow.
Hmm, looks like it was something else in the form of a screwy hazel rule that was deleting files immediately instead of then they were > 1 week old.
 
Quote:
Originally Posted by RiK View Post
Hmm, looks like it was something else in the form of a screwy hazel rule that was deleting files immediately instead of then they were > 1 week old.
Long ago, after being screwed by the Xerox Dandelion workstation's DWIM (do what I mean) "correction" feature, which rarely if ever did what you meant, a colleague made the following observation:

"The problem with programs that wipe your nose for you is they often wipe something else first!"

Whenever I see something that looks like it could do something really cool like delete outdated files for me after I just set it and forget it, I think back to that observation and step away from the keyboard until the temptation passes :-)

I'm glad you didn't suffer a permanent data loss, just a few grey hairs :-) Did you find anything else of importance misfiled in the trash? I know someone who somehow managed to operate for months with their mailbox in the trash. Obviously, emptying the trash was not part of their regular activities. Everything was fine until I suggested they empty the trash while I was trying to help them debug an unrelated problem. Oops.
 
Quote:
Originally Posted by whpalmer4 View Post
Did you find anything else of importance misfiled in the trash?
Nah, just the Omnifocus backups as I had a specific rule for them. Can't quite figure why they were getting trashed though as the rules was specifically for files > 1 week old.
 
You should base your Hazel rule on "Date Added" not on "Date Created" or "Date Last Modified". The creation date and modification date aren't updated when you make a backup; they reflect the time the database itself was created/modified.

Here's a screenshot of my Hazel rule:

Click image for larger version

Name:	Picture 1.jpg
Views:	279
Size:	18.3 KB
ID:	584

Hope this helps.

-Dennis
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dangerous Sync Problem? (data loss) Mike1000 OmniFocus 1 for Mac 8 2013-03-24 11:14 AM
CRASH and Data Loss RedHead OmniFocus for iPad 6 2012-06-05 10:10 AM
data loss when entering data during sync kasi OmniFocus for iPhone 3 2009-11-21 09:06 PM
Data Loss After New Version Install? sundevil67 OmniFocus 1 for Mac 2 2007-10-08 05:02 PM
Devastating Data Loss Dominus OmniOutliner 3 for Mac 3 2007-08-27 12:56 PM


All times are GMT -8. The time now is 09:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.