The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
line and circle trouble Thread Tools Search this Thread Display Modes
This is a very simple question, hopefully someone can help.

- I open a new drawing
- I draw a circle
- I draw a line from the center of the circle to its edge
- I resize the circle
- The line disappears into a green dot
- I want to be able to resize the line to again extend to the circle but I cannot
- Attaching screen shot of final view
 
The screenshot didn't come through, but I think I know what happened. You've been hit by OG's not-always-useful default connector behavior. A default shape will have "Allow connections from lines" checked (Properties>Connections Inspector), but no magnets. In this case a line will connect to the center of the shape but be drawn only outside the shape.

It sounds like your line connected to the circle's center, and perhaps to its edge as well. Since none of it is outside the circle, it's invisible.

The easiest way around this is to set up the circle with a magnets on its edge and center. You can put them on the edge using the pulldown in the Properties>Connections Inspector or by using the magnet tool. You have to use the magnet tool for the center one, and the circle must be filled. (You can turn off fill later if you want.) Turn on View->Magnets so you can see the magnets. First place the center magnet anywhere in the circle. Then move it, again with the magnet tool, until it snaps to the center. You'll see alignment lines when it does.

Then carefully draw a line from the center magnet to an edge magnet. This can be tricky, because the line will try to connect to the circle's edge, too, and then you're back where you started. The key is that the about-to-be connected item will pulse blue. Make sure that it's the edge magnet and not the edge itself that's doing it.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with drawing line in a circle santra OmniGraffle for iPad 2 2011-05-23 09:57 AM
bezier line + circle, initial magnetic does not stay fixed naromero OmniGraffle General 1 2010-10-14 07:30 AM
Trouble setting line geometry SSteve OmniGraffle General 2 2010-04-28 07:24 AM
Strange behavior of line and circle or bug ? jochen OmniGraffle General 2 2009-06-23 05:31 AM
drawing a line inside a circle Thinksamuel OmniGraffle General 1 2009-05-27 12:27 PM


All times are GMT -8. The time now is 10:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.