The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

1.1.4 Attachment View? Thread Tools Search this Thread Display Modes
The release notes say:

It's now possible to view attachments containing Microsoft Office documents, plain text files, and web archives.

How do I do that? I saved a Word attachment to the note of a task in OF Desaktop, synced, but don't see the attachment anywhere in the task on the iPhone.
Well, I've been testing this for an hour. I cannot get an Office, txt, or Web Archive attachment to sync to the iPhone. Email has already been sent to tech support. I am running iPhone 1.1.4 (v77. built 2008-12-04 00:07:36 -0500
You're sure you actually embedded the file itself, not a link? The default is to make a link...
Originally Posted by whpalmer4 View Post
You're sure you actually embedded the file itself, not a link? The default is to make a link...
I tried both. I'll try again.
Originally Posted by whpalmer4 View Post
You're sure you actually embedded the file itself, not a link? The default is to make a link...
Nothing. I'm doing this by the book. Photo and audio attachments work fine. There appears to be no new icon for other types of attachments, so I suspect a faulty install. But it seems to work perfectly otherwise, and it has 1.1.4 as the version number.

Very confusing.

Is anyone else getting these attachments to sync over to the iPhone? I'm watching Twitter on this, and so far no one's confirmed it yet.
Still no luck after complete reinstall:

Deleted OF from iPhone, including all files
Full reboot of both Mac and iPhone
Confirmed OF no longer on iPhone
"Repurchased" iPhone OF from iTunes Store
Launched OF 1.1.4 on iPhone
Chose Set Up Sync
Opened Desktop OF
Let Desktop OF sync
Opened Preferences, Sync
Bonjour Sync already set up (previously working fine)
Clicked on "Share Settings"
iPhone OF registered name of computer
Tapped on same
iPhone OF synced
All Tasks and Projects and Contexts present and accounted for on iPhone
NO Word, Txt, or Web Archive attachments on iPhone
All Word, Txt, or Web Archive attachments in Desktop OF still there and readable
Confirmed that 1.1.4 build on iPhone identical to that before data wipe

This camper still frustrated and unhappy.
Are you looking in the attachments section at the bottom of the action detail screen? (Attachments don't appear inline on the iPhone, as they do on the desktop.)

Even in 1.1.3, you should have seen all your attachments listed; the difference in 1.1.4 is that you can preview your Microsoft Office attachments (where before you'd just see their filenames listed).
OK, well, apparently there are a LOT of different ways to attach a file to an item (action), but not all them result in an attachment that will sync.

One method that does NOT work is selecting the item, chosing Edit, Attach File. One method that DOES work is Option-Click-and-Drag the file right onto an action. This was tweeted to me by @shrop on Twitter. (Twitter is now faster than all support desks and even Google at solving problems.)
Clicking and dragging a file into white space, or between tasks, to create a new item with the file as an attachment in the note, also does not work--whether you have the Option key held down or not.
Here's the solution to the puzzle, right from the OmniFocus manual:

By default, OmniFocus creates links to the files you attach, rather than adding the files to your OmniFocus database. This keeps your database from growing needlessly (which is especially important if you are syncing your data), but the link will break if you delete the file or put it somewhere OmniFocus canít find it. To make OmniFocus copy a file into its database for safekeeping, hold the Option key as you drop the file, or select Embed the file in the document in the Attach File dialog.

And that is apparently what you have to do: force OmniFocus to make a copy rather than a link. Problem is, it's not always completely apparent what's going on.

But if you're dragging and dropping, make sure you hold the Option key down while doing it (you'll see a "+" instead of the little black arrow that you would see for a link/alias). If you're using the Edit menu to attach, make sure you select "Embed the file in the document" (which is not the default).

If you're copying the file and then using paste to paste it in the comment, that seems to work...but I'm not sure. If you're dragging right into white space...well, again, I'm not sure.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Attachment size limitations GrumpyDave Forums Feedback 3 2011-02-18 05:13 PM
Attachment List Bug? BobCollins OmniFocus 1 for Mac 5 2011-01-08 08:53 AM
Attachment from Mac sync to iPad jepa OmniFocus for iPad 2 2010-08-16 08:57 AM
File Attachment ckeseling OmniPlan General 4 2010-06-17 11:15 PM
Attachment Icons v. Links new user OmniFocus 1 for Mac 5 2010-04-09 11:12 AM

All times are GMT -8. The time now is 01:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.