The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Aliased fonts using the Text tool Thread Tools Search this Thread Display Modes
Hello, I'm using the text tool to create diagrams for posting on the web. Most everything is working great, except that all the fonts I try to use end up aliased, which looks really terrible. Is there a setting I need to turn on, so that it looks good? Even at 18pt, it my diagram on screen looks like something off an old dot matrix printer. -- john
 
This is actually a flaw in OS X, not OmniGraffle. Pages (at least version 1.0) has the same issue as would any other app that has to display fonts in the same way. I forget the actual cause of the problem, but a google search should pull something up on it.
 
But it's been a long pain since I start using Omnigraffle, and this problem still exist on leopard. Hopefully Omni can do something workaround. I really really really want to this problem to be solved. here is the link if you want to experiment with the problematic .graffle file: http://rapidshare.com/files/67774933/textRender.zip
Attached Thumbnails
Click image for larger version

Name:	textRender.jpg
Views:	416
Size:	69.4 KB
ID:	361  
 
So... I take it from the sheer lack of response that no one else uses OmniGraffle to create graphics for the Web? Because that's one of the main reasons I bought it: to add illustrations to my blog. The current text rendering support renders it nearly useless for that purpose, however, as the text in my illustrations looks like I scanned a photocopy of a badly printed book.

This would seem like something that people would really want to do. Note that I can export to PDF and then do a screenshot of the PDF in Preview and the text looks just fine. So why again can't OmniGraffle render text as well as Preview?
 
Omni folks, any reply?
 
I'm not the Omni folks, but here is the explanation for why this happens:

http://michelf.com/weblog/2006/subpi...achilles-heel/

jwiegley - I'm confused as to how OmniGraffle's display is a problem for web graphics unless you are doing a screen grab to obtain them? Exported and copy/pasted images should look fine.
 
Quote:
Originally Posted by JKT View Post
I'm confused as to how OmniGraffle's display is a problem for web graphics unless you are doing a screen grab to obtain them? Exported and copy/pasted images should look fine.
Hello! Exported images are exactly what I'm having the problem with. I export the image to the clipboard so I can paste it into RapidWeaver, where I then publish it to the Web.

John
 
jwiegley,

I use Graffle with RapidWeaver all the time. I have no problem with fonts, even as small as 10, 11 points.

I don't think you're technically "exporting" the image. What I do is export the image to a PNG format--the diagrams/tables remain very small in size and look great when used in RapidWeaver.

Unfortunately I can't replicate what you do. I always get a "pasted graphic" text in my published site if I replicate the steps you describe.

But if you truly export the image as PNG to your hard drive then drop it into RapidWeaver as an asset it works fine.
 
It turns out this problem was very easy to solve, there was simply one fact I didn't realize: OmniGraffle, being a vector drawing program, can rasterized at any DPI. Therein lay my problem.

When I copied the object to the pasteboard for dragging into Scrivener (and from thence to RapidWeaver), it was rasterizing at a default dpi of 72. Of course, 72dpi is even less than my screen's resolution, which is what caused the result to look like it had been xerox'd from a poor photocopy.

Instead, I selected the graphic I wanted to export, choose File | Export from the main menu, and then picked a PNG file at 600dpi. This, of course, produced beautiful text within my exported graphic.

John
 
Apps in OS X place several versions of their images on the pasteboard and apps request the highest quality version they can utilize. Most apps in OS X are happy with the .PDF format, some apps aren't.

Try this, copy your text, open Preview, and do Command-N. That creates a new file from whatever's on the pasteboard. You should see that the file that gets created is a .PDF. So, the output from OG is a high res vector image for the apps that can accept it. I don't have Scrivener, but I'd imagine that it's not placing a high resolution PDF back on the pasteboard for RapidWeaver.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I change background/text color, fonts, and styles? [Colour] gruber OmniFocus 1 for Mac 26 2010-06-09 02:21 AM
Text Scaling and Graffle as an IXD Document Tool LawKitson OmniGraffle General 1 2010-05-17 06:20 PM
How do I change text notes fonts stolzy OmniOutliner 3 for Mac 4 2010-02-25 05:35 PM
Fonts in OG wbrisett OmniGraffle General 2 2009-12-08 01:32 AM
Diagramming Tool -> Edit Text conekt OmniGraffle General 2 2008-12-09 05:13 PM


All times are GMT -8. The time now is 09:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.