The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Am I doing something wrong? Workspaces Thread Tools Search this Thread Display Modes
Can you be more specific about what you're seeing?

If you have a workspace with a snapshot saved, and all the windows are closed when OmniWeb shuts down, the app is going to automatically restore the workspace from the snapshot next time you load it.

Trying to help, but I'm not sure what "losing the workspace" means exactly.
 
A workspace can be in one of 4 states:

No snapshot, "Auto-save while browsing" setting disabled.
No snapshot, "Auto-save" enabled
Has snapshot, "Auto-save" disabled.
Has snapshot, "Auto-save" enabled.

Do any of those four states do what you're after? If not, what would need to be different? We don't know when we'll have time to work more on OmniWeb, but I can certainly write up a feature request for you. :-)
 
Quote:
Originally Posted by Brian View Post
Can you be more specific about what you're seeing?

If you have a workspace with a snapshot saved, and all the windows are closed when OmniWeb shuts down, the app is going to automatically restore the workspace from the snapshot next time you load it.

Trying to help, but I'm not sure what "losing the workspace" means exactly.
I have 3 workshops set up:

1 - Browsing (with snapshot)
2 - Bill Paying (with snapshot)
3 - Default (no snapshot)

Default isn't a problem as I don't have anything saved in that, but if I'm on say browsing (like now) and I close the omniweb down. When I reopen and go to the browsing workspace - it's blank, until I say to restore snapshot workspace.
 
Quote:
Originally Posted by 4kidsat147 View Post
Yes this is checked. It does a pop up when I close the window saying do you want to close all tabs and of course at first I said yes as I figured they were saved anyway..
No, that comes up because you are closing a window with multiple tabs, not because of any workspace options.
 
Quote:
Originally Posted by 4kidsat147 View Post
Default isn't a problem as I don't have anything saved in that, but if I'm on say browsing (like now) and I close the omniweb down. When I reopen and go to the browsing workspace - it's blank, until I say to restore snapshot workspace.
Can you walk through it step-by-step, so I can try them here?

Which of the four states I mentioned above is the workspace in? What workspace are you in when you quit the browser? Browsing, or have you switched to a different ones? What windows, if any, are open (including in the dock) in Browsing when you switch away from it or quit the app?
 
Quote:
Originally Posted by Brian View Post
Can you walk through it step-by-step, so I can try them here?

Which of the four states I mentioned above is the workspace in? What workspace are you in when you quit the browser? Browsing, or have you switched to a different ones? What windows, if any, are open (including in the dock) in Browsing when you switch away from it or quit the app?

The workspaces are in:

Snapshot Taken: Auto-Save while browsing. (both my F1 & F2 browsers)
NO Snapshot Taken, NO Auto-Save (F3 browser)

If I'm in any workstation and close down the browser I loose the status of it. (I expect it with the F3 browser, but not F1 & F2)

They remain if I'm moving between workspaces - that's not an issue.
 
You need to check the Auto-save button for each workspace that you want to remember your active browsing state. When you come back to that workspace after restarting OmniWeb, you'll get your windows as close to how they were as is possible (often including partially filling out forms). If you want to go back to the "clean" state, just click the restore snapshot button in the workspace window and the windows and tabs you've accumulated since taking the snapshot will be discarded.

Well, that's how it is supposed to work, and works for me. Re-reading your post, I see that you've got it set that way, I misread the first time.

Last edited by whpalmer4; 2011-02-16 at 10:56 AM..
 
How are you closing down the browser? And which version of OmniWeb are you running?
 
Quote:
Originally Posted by whpalmer4 View Post
How are you closing down the browser? And which version of OmniWeb are you running?
I close it down by the red x and I'm running the latest version (or at least I assume so as I've only had it for about 3 days)

What your saying makes sense to me, that's why it's not making sense that mine isn't doing that.
 
Quote:
Originally Posted by 4kidsat147 View Post
I close it down by the red x and I'm running the latest version (or at least I assume so as I've only had it for about 3 days)
What red x is that? The only red x I see is the toolbar button which stops loading the current page. Do you mean the red dot at the upper left of the window?

If you click the red dot, you are not closing the application, you are closing the window, just as if you had used the Window->Close Window menu command. OmniWeb remembers that you threw away that window and updates the workspace accordingly. If you instead quit OmniWeb (via cmd-Q or OmniWeb->Quit OmniWeb), your workspace state will be retained for next time. This gets back to my earlier comment about wanting OmniWeb to read your mind: how is the program to discern that you closed that window (with the click on the red dot) because you just didn't want it cluttering up your screen, and not that you closed that window because you don't ever want it again?

As for the version, standard Mac practice is there is an "About <XYZ>" command as the first item in the <XYZ> menu which will report the exact version you are running. While no updates have come out in the last few days, there is still the question of whether you are running the "production" version or the "sneaky peek" version, both of which are available to you, though I would expect you probably have the "production" version. It sounds like the problem is simply with how you are using the program, however, not that it is working other than as designed.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
exporting workspaces? FredH OmniWeb General 2 2007-07-25 05:18 PM
Idea: Workspaces steve OmniFocus 1 for Mac 3 2007-06-09 01:07 AM
Workspaces... I Don't Get It. Heavy Doody OmniWeb General 8 2007-05-08 04:52 PM
Workspaces? gray49 OmniWeb General 7 2006-07-23 10:39 PM
Workspaces... TommyW OmniWeb General 8 2006-04-15 12:17 AM


All times are GMT -8. The time now is 03:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.