The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iDisk/MobileMe/.Mac Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

1.1 OF iDisk Sync Broken Thread Tools Search this Thread Display Modes
I already sent feedback to omni on this issue but thought I would post my issue in case anyone else has feedback or seeing the same thing.

I recently got my Macbook Pro replaced and had to move over my OF
library. Prior to this I had sync working just fine with my old MBP,
Power Mac G5, and iPod Touch.

When I first moved the library over everything over to the new MBP
the .ofocus loaded up fine. When I went to sync for the first time it
spent 20-30 min. syncing before it came back that it had failed. I
looked at my file size and it was ~28MB which seemed ridiculously large.

I have since tried all kinds of options:

1) Backup database and Revert from backup but file size was still 27MB
2) Started completely over with a fresh install and fresh .ofocus file
to sync, same issue.
3) Moved everything off idisk and started with brand in .ofocus just
to see if would sync with a brand new small file size and same issue.
I saw in the other thread you tried the compact script and it didn't work. If you haven't heard from our support ninjas personally yet, could you please reply to the auto-response email you received with a list of the files that are inside the OmniFocus.ofocus file on your iDisk? (Right-click on the file and choose Show package contents)
There was just one file listed:

I replied to the auto email with the number as well.
Originally Posted by laner19 View Post
There was just one file listed:

I replied to the auto email with the number as well.
I seem to be having the same issue as laner19 (and I just sent a "help!" e-mail off to the ninjas about it).

In my case, the file name is:

Any solutions available?


So, I decided to see what was IN that massive .zip file by copying it and unpacking it. It seems that I've managed to COPY in some files that I thought I was LINKING in to the DB. Any easy way to remove the embedded files?

[END at 3:18 PM in GMT -4]

Last edited by jet14; 2008-08-01 at 11:18 AM..
Do NOT delete the files directly from the .zip. You'll need to go find the actions in OmniFocus and delete the attachments through the UI.
So that's the problem I'm having: none of these files seem to HAVE an existing action associated with them. I went through the .xml file, found the "ActionID" associated with each of those files, and those IDs just don't seem to exist anyplace else...
PROBLEM SOLVED! (I think... of course, after I'd already done this Lizard posted to say I'd done the equivalent of "crossing the streams" in Ghostbusters. Only time will tell.)

I simply made a backup of my DB to the desktop, viewed the contents, opened that single .zip file with "Stuffit Archive Manager" and purged all of the gargantuan embedded files. Once I was done, a 32 MB file had been slimmed down to a mere 228 KB (now 232 KB after modifying an item).

Overall, my sense is that I hit some data-gremlins a while back, and all of these files got sucked into my DB inappropriately. After making this change in the "backup" DB, then reloading that DB as a "Restore", I do not seem to be experiencing strange behavior. Well, not unless you call iPhone sync times that don't stretch on forever "strange".

I think I've had stuff like this in my DB for ages, so I'll see how things go post-cleaning.

Let me know if you guys want any of my DB backup files with the bloat; maybe you can figure out how it happened (or, even better, build in an automatic correction function in a future build!)

Thanks again,

jet14: yeah, it sounds like something went wrong with the DB a while ago. Maybe I should have said "Do NOT delete the files directly from the .zip unless you're really careful and working with a backup and the ActionIDs don't appear anywhere else in the DB."

Glad it's working for you. We did fix a bug that might have caused this, back in October. With those attachments not being associated with any existing ActionID, I doubt we could reconstruct the scene of the crime, but thanks for the offer.
Originally Posted by Lizard View Post
Do NOT delete the files directly from the .zip. You'll need to go find the actions in OmniFocus and delete the attachments through the UI.
One thing I noticed is that when I had a bunch of emails clipped in from, said emails containing some photographs, that it wasn't sufficient to simply remove the photos by editing the notes field. I only got the space back when I ran the CoalesceDatabase script posted by Lizard. I believe this is a known bug, but I sent feedback anyhow.
whpalmer4: If the script fixed it, then the attachments were still sort of associated with actions, and deleting them directly would have caused corruption.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
What to do now with iDisk sync rogbar OmniFocus 1 for Mac 5 2011-10-18 11:48 AM
help with idisk sync cjjeeper OmniOutliner 3 for Mac 0 2011-06-14 04:04 AM
Omni Sync server vs iDisk sync Nicolas_Thomsen OmniFocus Syncing 5 2011-02-09 02:25 PM
iDisk syncing completely broken esoterica iDisk/MobileMe/.Mac Syncing 9 2009-06-21 10:42 PM
Sync with iDisk AND Bonjour? Asmeco OmniFocus Syncing 1 2008-11-19 06:36 AM

All times are GMT -8. The time now is 03:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.