The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
How to Edit Subgraph? Thread Tools Search this Thread Display Modes
I'd like to use the subgraph feature to expand-collapse process-subprocesses diagram. I've grouped several subprocesses in a sub graph but noticed I didn't have a line connector between two sub-processes. How can I add the connector to the subgraph? How could I add another sub-process within the sub-graph.

I really don't want to ungroup, add the connector, reselect, (perhaps forget another piece), then regroup. I'd really like to drag-n-drop the connector onto the subgraph or open another window to edit the subgraph, or ...?

Further, I could see building a high level diagram and then returning to individual processes to add sub-process details (and details to those sub-processes, ad nauseum)

Perhaps, this is a feature request in disguise. Or, I missed a step. Or, ... Heelllllpppppp!?

Keep up the great work.
 
You can set whether to connect to the group as a whole or to its components in the Connections Inspector (even though it says group, it works for subgraphs as well). If it's set to connect to the components, then you don't have to ungroup to connect a component to another component in the subgraph.
__________________
"Vroom! Vroom!!"
 
Thanks for your quick reply.

I guess I wasn't clear.

The two object I'm connecting are within a subgraph. I tried what you suggested, however, the connector remains outside the group and visible when group is collapsed.

And I want to add another Object inside an existing (and perhaps complex) subgraph. The added object should become part of the subgroup.

TIA,
Rivkah

Last edited by Rivkah; 2008-03-14 at 08:53 AM.. Reason: Further Clarification
 
Hummph. I can connect two objects inside a subgraph just fine on my end, so long as that connection setting allows it.

You can also manage this as well as add objects within the subgraph in the Outline Editor.
__________________
"Vroom! Vroom!!"
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
subgraph questions mitchellm OmniGraffle General 3 2011-12-02 11:45 PM
subgraph zoom marcussommer@mac.com OmniGraffle General 0 2010-05-30 08:17 AM
Add to a subgraph lutherbaker OmniGraffle General 1 2008-09-07 11:11 AM
subgraph questions markb OmniGraffle General 1 2008-05-04 01:41 PM
subgraph in dot Bin Hu OmniGraffle General 1 2008-04-01 03:50 PM


All times are GMT -8. The time now is 04:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.