The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Locked object dragged along with connector midpoint? Bug or PEBCAK? Thread Tools Search this Thread Display Modes
New user to OG Pro 5.02, running on MBP/10.5.5/4GB. Open this drawing:

http://kan.org/download/DragMe.graffle

Note that the large white "frame" (really just a rectangle) at the back is _locked_.

Select the little white box that the connector arrow is going into, then drag it around to move it. The large white frame moves, too, even though it's supposed to be locked. (you can select other stuff, too, as long as you don't select the box the connector is coming from.)

The root problem seems to be that the midpoint of the connector is somehow tied to the big white frame. If you move the midpoint, the frame moves. If you select and delete the connector, the frame disappears. But if you select them both, you can't ungroup them, so they're not grouped.

Is this a bug, a corrupt file, or did I somehow turn on a feature that I don't know how to turn off?
 
That large locked rectangle has become a line label for the line running up to the smaller box.

Any shape can be dragged directly onto a line to convert it to a line label, which is what I think has happened here accidentally.

So, regardless of its locked state, it moves around as the line moves around.

Think I'll muck around with locking line labels, etc. and at least file a bug about that.

Thanks for pointing this out, and I hope the above information helps.
__________________
"Vroom! Vroom!!"
 
Ok, that explains it. I did this again (intentionally), and I can see how I might have done it inadvertently.

Once I've dragged a shape onto a line, how do I remove it and make it a standalone object again?

Thanks!
 
You can just drag it off of the line far enough and it will become a "regular" shape again -- If you know you don't want to ever have a shape to become a line label there are controls for this in the Connections Inspector.
__________________
"Vroom! Vroom!!"
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Object/connector placement doesn't survive VDX export stevenkan OmniGraffle General 4 2014-05-15 09:41 AM
How do I align an object parellel to my connector? amit_e OmniGraffle General 0 2011-03-06 08:32 PM
Titles of dragged links? JDub OmniOutliner 3 for Mac 1 2007-02-15 01:19 PM
Bookmarks are copied, not moved, when dragged ebob OmniWeb Bug Reports 5 2006-12-17 06:51 PM


All times are GMT -8. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.