The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Error when syncing to WebDAV if there's a port number specified Thread Tools Search this Thread Display Modes
Hello,

I'm trying to sync my OmniFocus to a WebDAV directory i just configured on IIS 6.0. The server is on port 8080 since the ISP blocks port 80.

http://myhostname.com:8080/omnifocus/gabriel/

This won't work, and it has to do with the port number. OmniFocus is able to create the file on the server (copy-in-progress or something like this), but it fails afterwards with the following error:

Could not access the WebDAV location “myhostname.com/omnifocus/OmniFocus.ofocus/ofcfxuzowXi.client-write-in-progress-oK2f1sBxUQS”.

If I do the same thing, but using the internal IP address without specifying a port number, it works fine.
 
I'm sending an email over to the QA folks; we'll look into this tomorrow. Thanks for reporting it!
 
I'm seeing the same behavior. It looks like a port number specified in the URL is ignored or parsed incorrectly.
 
Using a non-standard port works for me (at least Omnifocus does connect to the server and is able to read and write files there). But I always get the message "Your database couldn't be synchronized, because the database on the server appears to be totally unrelated to the local database". I don't know if the two are related.
(See me post in the thread "Sync always triggers "no longer compatible" message")
 
Any update on this issue?
 
We haven't been able to reproduce this here yet. I'll file a bug though, to make sure we don't forget to look into it again soon.
 
I'm still unable to sync using port 8080... the URL i'm trying to use works fine if I try to mount the WebDAV share from the finder. Sync works perfectly if I use the default port.

If Omni needs a sample URL to test please contact me by e-mail.
 
The content of my OS X log. It seems that a part of the synchronization process ignores the port number I set. It prompts for a username and password and succeeds in uploading one file, but times out afterwards...

08-08-18 19:50:26 OmniFocus[6394] sync started
08-08-18 19:50:41 OmniFocus[6394] Disconnected transactions:
{(
"<XMLTransaction:0xdd54640 20080720144548=bmp11Sx8IZk+nujm3Thsmui.zip>"
)}
in:
http://servicessipd.com:8080/omnifoc...iFocus.ofocus/
08-08-18 19:50:41 OmniFocus[6394] transaction = <XMLTransaction:0xe2c8770 20080717203637=bmp11Sx8IZk+bmp11Sx8IZk+k1wYBiNKlkq .zip>
08-08-18 19:50:41 OmniFocus[6394] copying 0 files to remote, 0 from remote for a total of 0 bytes.
08-08-18 19:50:41 OmniFocus[6394] wrote client state to http://servicessipd.com:8080/omnifoc...TynmvpY.client with identifiers (
"pUe_2Njw5Sw"
)
08-08-18 19:50:41 OmniFocus[6394] transaction = <XMLTransaction:0x12af19a0 20080717203637=bmp11Sx8IZk+bmp11Sx8IZk+k1wYBiNKlkq .zip>
08-08-18 19:50:44 OmniFocus[6394] Disconnected transactions:
{(
"<XMLTransaction:0x149613a0 20080720144548=bmp11Sx8IZk+nujm3Thsmui.zip>"
)}
in:
http://servicessipd.com:8080/omnifoc...iFocus.ofocus/
08-08-18 19:52:02 OmniFocus[6394] sync terminated with error: {
code = -1001;
domain = NSURLErrorDomain;
userInfo = {
NSErrorFailingURLKey = "http://servicessipd.com/omnifocus/gabriel/OmniFocus.ofocus/20080812130239=fkW4Lpykfyz.client";
NSErrorFailingURLStringKey = "http://servicessipd.com/omnifocus/gabriel/OmniFocus.ofocus/20080812130239=fkW4Lpykfyz.client";
NSLocalizedDescription = "timed out";
NSUnderlyingError = {
code = -1001;
domain = kCFErrorDomainCFNetwork;
userInfo = {
};
};
};
}
 
I think this is pretty much what is happening to me too, when I try to sync to the webdav over an ssh tunnel. I have port 8080 forwarded to port 80. Then from my laptop, I open an ssh tunnel to my desktop.

Then I put the following url into OF: 127.0.0.1:8080/webdav

From there, I get the same behavior as the folks here. Those weird folders are in the web dav directory, and the sync fails.

I can open the webdav volume fine from the finder or from goliath. I can add files to the folder, and move them out, trash them, etc. But I can't sync OF.

Conversely, if I am within my LAN and using the standard port, the sync works.

If would be great to get this working. SSH may not be as slick as SSL in every respect. But from what I can gather, it's easier to get it configured. It's already built into OSX. And it's a secure way to sync remotely.

I'm guessing that within within the next month or two, there ought to be an ssh client on the iphone that will allow tunneling as well.

It's not as seamless as mobileme. But for people who must retain control of their data (or cheapskates), it would be nice to have this as a more secure option.
 
Just wanted to bump this up again. Has anything been done to address this issue?
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Applescript error number -1728 when trying to specify a project name for a new task benlanghals OmniFocus Extras 3 2011-12-30 05:55 PM
How to find project id number in downloaded webDAV database jc786 OmniFocus for iPhone 0 2011-12-14 03:28 AM
Alternate port for WebDAV dmarkow Other WebDAV 1 2008-07-18 01:56 PM
iPhone Webdav sync with non-standard port jtynefield Other WebDAV 1 2008-07-16 04:41 PM
Error when syncing with webdav ryanirelan Other WebDAV 3 2008-07-13 03:41 AM


All times are GMT -8. The time now is 03:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.