The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Browsers: working on CSS 3, but still lack HTML 4 Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Over the past several years, I've noted that most browsers were really slow to pick up the new features that HTML 4 added to the HTML standard... features like data grouping in tables (which can save a ton of markup, and is extremely helpful in building accessible web sites). I've wanted to use these features a number of times, but after doing so then having to redesign for lack of support one too many times, I finally gave up and pretty much washed that knowledge out of my head.

Yesterday, however, I found myself on the browser text page at the iCab site, where I was reminded of some of the great unimplemented features. A quick check of OW shows that even as of 5.5b3, there still remain gaps. Interestingly, Firefox seems to do okay now--they must have beefed up their HTML support in recent versions.

So my question is: what happened? With nearly every browser claiming full support of HTML 4, why is it major ones in fact don't support major features of the standard? It's like they supported 3.2 then called it quits on the v4 features, and no one noticed in the buzz surrounding CSS.

Is there any chance OW (Web Kit) will ever be able to pass a simple HTML test like that on the iCab site?

To see the page, go here:

http://www.icab.de/test.html

(BTW, something that isn't tested on that page is allowing the user to click on a form control's label and have it act like a click on the control itself. This is especially important in a Mac browser, since Mac-native controls have always worked this way. And yet, it's rarely implemented.)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Working around lack of tags for projects joshfree Applying OmniFocus 6 2013-02-08 02:12 PM
Dynamic HTML not working GreenFlowers OmniOutliner 3 for Mac 2 2010-10-28 05:04 PM
OW renders a site different from other browsers John Stalberg OmniWeb Bug Reports 2 2007-04-16 09:45 AM
zoom window behavior vs. other browsers FredH OmniWeb General 4 2006-12-06 09:59 PM
View in other browsers jimlongo OmniWeb Feature Requests 2 2006-09-29 01:32 PM


All times are GMT -8. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.