The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Frustrated beyond belief, but hopeful Thread Tools Search this Thread Display Modes
First, the obligatory caveat. I have used Omnifocus since its alpha stage, and have generally been very happy with it. I of course have some suggestions, and am eagerly awaiting the new version (please add a "today" feature), but at the very least it has been rock stable.

When I first heard about, and then saw, Omnifocus for the iphone, I was ecstatic. The idea of being able see and add tasks, and to utilize more efficiently those odd moments between other things when I was out of the office, made me very happy. I was eager to get a 3G iphone anyway (showing uncharacteristic patience, I did not buy iphone 1.0, and waited for the second version), and iphone omnifocus was the icing on the cake.

I waited in line on July 11, bought the phone, ran home and activated it. The first thing I installed was omnifocus. I had already been using the 1.1 desktop alpha, but I made sure I had the latest version. I signed up for the free trial of MobileMe, because I did not yet want to play with Webdav, and figured I could deal with this later. I was too eager to get omnifocus on my phone to start messing around, and it seemed that idisk was the most foolproof solution, at least in the short term.

Anyway, I first synced to idisk. This may be important - it took a long time, and then crashed, so I did it again. Everything seemed to work fine. I then emailed to myself the settings, and clicked the link.

From here, my memory gets a little fuzzy, because I have since tried to do this maybe 50 times since. Different things have happened about half the time, but the result has been the same -IT DOES NOT WORK. Usually, I am asked to replace my settings, and then get "copying data to remote database." The progress line gets about 1/3 of the way, and then the app quits. I have tried reinstalling the app. I have tried erasing the files on idisk and resyncing. I have opened the "omnifocus.ofocus" package, checked the .client files to see if the names were correct. They are. I have archived old tasks, so my sync file is down to about 280kb. I have tried erasing all the other iphone apps. I have, to the best of my ability, taken everything back to scratch, and started again.

I can not tell you how many times I have tried. I have emailed the support ninjas, twice. I have not heard back. I know there is a great deal going on, and that most people are up and running , but I would like to have heard back. I have put off writing to this forum because I hate to write something negative, especially when it is almost certainly my fault that it is not working.

I do not know what else to do. As best as I can tell, the omnifocus on my phone is sound (I have reinstalled it many times, and even downloaded it again to make sure it was not corrupted somehow) and the desktop app is fine. The appropriate files seem to make it to idisk , but the problem seems to occur in transferring the files from idisk to the phone. More often than not, after clicking the email link, after I am asked to replace my sync settings, I get the preparing to sync message, then copying data to remote database message, and then crash. I wonder whether, even after I erase the app on the phone, something stays behind and this is responsible for the corruption. I have no idea.

What I am looking for is either suggestions, or a description of known possible conflicts. For example, I use Mozy to back up. Is this a problem? I doubt it, but I have ruled out lots of things and am running out of possibilities.

Any thoughts would be greatly appreciated. This is rapidly taking on white whale proportions, and I freely admit that while this is completely irrational, I am so close I can't stop. This is, frankly, the most frustrated I have ever been using a Mac. I don't mean to throw Omni under the bus, their apps are great, and I know that they are extremely limited because of the way they have to deal through Apple. Despite the ridiculously long post, I am hoping that someone out there has stayed with me, and can help me.

Thanks for letting me vent. I hope to hear from someone.
I had similar problems with the progress getting stuck about a third of the way. This was also with about 280K of data, or about 2,000 actions. Omni support said that due to the amount of RAM the iPhone has, they don't recommend syncing more than 1,000 actions. I reduced my database to just under 1,100 (couldn't easily prune it further) or 140K, and since then it's been working perfectly.

Last edited by mjt; 2008-07-21 at 04:20 PM..
First, thank you to mjt for his help. One of the great things about macs and companies like Omni is the community. Really appreciated.

I tried mjt's suggestion, and had similar problems. I pared down the database until it was about 200K, but could not get it any smaller. So, I did something suggested elsewhere in the forum. I am sorry I do not recall the author, but his help is also greatly appreciated.

Following his lead, I copied my database to another folder, and omnifocus then created a new, blank database when I opened the program. I then doubled clicked the old database, to open it next to the new, essentially blank one, and dragged all my stuff from the old to the new. I deleted everything from, did a fresh sync, and then clicked on the email with the settings on my phone. This time, it worked perfectly, and subsequent syncs are going fine.

I used the old 1.0 OF, and wonder whether there was an issue with the upgrade to the new form of database in 1.1. I any case, it is working, and I am deliriously happy.

I am looking forward to further improvements, and thanks again to those in the forum.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated by modes, views, and sorting chartier OmniFocus 1 for Mac 4 2011-01-12 07:58 AM
Frustrated... wok4 OmniFocus 1 for Mac 4 2010-07-06 04:45 AM
Confused and Frustrated haig OmniFocus 1 for Mac 2 2008-08-27 04:48 PM
utterly frustrated with magnets krustyfur OmniGraffle General 0 2006-07-14 01:34 PM

All times are GMT -8. The time now is 10:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.