The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

spontaneous cursor movement to end still there [Fixed] Thread Tools Search this Thread Display Modes
hi guys.

I'm using the latest sneaky peak and the spontaneous cursor movement is still there, regrettably.

typing within the URL field, or within a form field, there are times when you press the right arrow and the cursor is sent all the way to the end of the field. very inconvenient!

please fix it.

I can reproduce this:

1. in OW's Address Field, type "google abc def" and press return.
2. click after the text inside the search field on Google's search result page.
3. press the Up arrow to move the cursor to the beginning of the line.
4. press any character. I pressed 'z'.
5. press option-right-arrow to move to the end of the zabc word.
--> the cursor moves to the end of the field.

hope this helps.

more: actually, it's easier to reproduce than this.

2. click *anywhere* within the search field of the Google search result page.
3. type *any* character (important).
4. press the right arrow (option modifier not necessary).
--> the cursor moves to the end of the field.

Last edited by Gregory; 2008-09-11 at 06:55 AM..
I was able to reproduce this with your recipe.

I tried a few variations on your recipe to see if it always behaved the same way. One of the times I did it, I distinctly saw the right arrow step move the cursor over one character, followed by the briefest of pauses, and only then move it to the end of the line. This can be demonstrated by moving the cursor one character right with the arrow before typing anything, then using it after typing. (Search, click in results search box, right arrow, type a character, right arrow and see anomaly)
is this ever going to be fixed? not only does this occur as described above but the cursor spontaneously jumps to the end by typing letters not just pressing the arrow keys.

this has bugged me for over 1 year now.
still no fix? is this even looked at?
Hello, sorry for the trouble here. This will be addressed for a future release, I apologize that it has not been corrected as of yet.
Hi, still no love for this bug? Any update on this? Anyone at OmniG made any progress?

No promises but we do have this on our short term bug fix list.
Troy Brandt
Omni Person
Thank you to those who fixed this one! It's been annoying me at a kind of background level for a while, but I'd always blamed the site rather than the browser and so never reported it.

Many thanks!
Im having success so far so it appears this bug has def'nly been vaporised. phew...

Thanks OmniCrew ;-)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fixed Cost, Fixed Duration, Flexible Effort/Resources metasim OmniPlan General 2 2012-02-03 04:24 PM
Spontaneous crashes with 5.11 sneaky peek andreas_g OmniWeb Bug Reports 18 2011-11-13 06:14 PM
Unwanted Bezier Curve Endpoint Movement moniker OmniGraffle General 1 2010-05-19 11:13 AM
Spontaneous change of perspective sawxray OmniFocus 1 for Mac 6 2009-04-23 09:16 AM
Possible to remap cursor movement combos? pergesu OmniWeb General 1 2007-11-28 01:54 PM

All times are GMT -8. The time now is 09:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.