The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Some Ruby on Rails Cookies/Sessions Don't Work? Thread Tools Search this Thread Display Modes
I am a Rails developer and while I usually use Safari and Firefox, I am testing out OmniWeb 5.5. I really like it but I am having some problems with my Web apps.

I have a session/login implementation for my apps and without getting into specifics, we use cookies and redirects.

Works fine in every browser on Windows and OS X but w/ OmniWeb it doesn't work, I just get sent back to the login page. Basically, the cookies aren't being sent back to the Web server like they should be in this specific instance.

This probably requires someone from Omni to look at the app specifically and I would be happy to provide either a test RoR app that does it or a live site to look at the headers.

Contact me at hunter AT liberationmedia DOT com if you are interested in troubleshooting this bug.
 
Are you testing this application on a local machine? I've run into a similar problem where temporary cookies would be cleared on each pageload, but only when running the server locally. Works fine when it talks to a remote server. A workaround is to map some other address to 127.0.0.1 in your hosts file.
 
No, it happens on both my production and test servers, as well as localhost.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
GTDmomma: ruby script that nags you meesterdude OmniFocus Extras 0 2012-02-29 04:30 PM
Adding tasks from Ruby or YAML Martin Oldfield OmniFocus Extras 2 2010-11-15 03:18 PM
setting Text properties using Ruby appscript or RubyOSA Joe.Hocker AppleScripting Omni Apps 1 2009-02-14 01:20 AM
OmniWeb and saved sessions between closing jposel OmniWeb General 2 2006-08-13 08:52 AM
Localhost cookies don't work properly kballard OmniWeb Bug Reports 0 2006-05-03 02:05 AM


All times are GMT -8. The time now is 04:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.