The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Font weirdness (helvetica regular looks like compressed) Thread Tools Search this Thread Display Modes
I've found that my OFocus and OOutliner both are displaying a substitute font for the left panel listings (project/context or utilities drawer). The apps can't seem to find the version of Helvetica they want, and are substituting. In my case, they substitute a bold compressed version of Helvetica that's nearly unreadable for that purpose.

Anybody know what precise Helvetica to feed these apps? Ideas about fixing this? (I'm going to post this thread topic under OOutliner as well.)


I'm having the same problem. What font does OF need?

Also as a side note - I would definitely want the option to choose a font that was designed specifically for screen reading - like Verdana.
OK - I just found out how to change the fonts (change one and they all change). So I'm set as that's all I needed to do.
Since upgrading to Leopard I have noticed a strange problem with OmniFocus:

When I started OF after the upgrade all the fonts had changed. After some investigation I found that the new font was Helvetica Compressed; initially I thought that the styles had become corrupted somehow so I deleted all style items from the .plist. No change.

Next I selected everything and tried to change the font to Helvetica Regular. It was already selected! Changing to another variant (Oblique) worked as expected, and Compressed appears to be correct (same appearance as I was getting from Regular). Other apps have no problem accessing and rendering Helvetica Regular correctly.

Does anyone have any similar experiences? I have searched about a bit but have not found any references to this specific issue.
Your solution probably lies in Font Book rather than OmniFocus - it is likely that you have a duplicate or other font that is conflicting with Helvetica that you need to resolve.
I responded in the other post - most likely you have a font duplicate or other font that is conflicting with Helvetica. If not, then clearing your font caches might help.
This is font conflict that occurs on Leopard. More info here.
Yes! and I have to add that it has been solved with the X.5.1 update: now you can add the old Helvetica font. An alert panels appears saying that it may create some conflict, but there is a new button that allows to do it. :)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Helvetica Neue is replaced with Helvetica randomly chattte OmniGraffle General 0 2012-09-18 11:46 PM
Setting screen font vs. print/export font [A: text zoom coming in OO4.] gmiddleton OmniOutliner 3 for Mac 26 2012-05-06 02:56 AM
Perspective weirdness Chris OmniFocus 1 for Mac 1 2008-01-08 12:49 PM
Print as PDF weirdness jmckeown OmniWeb General 1 2007-05-22 09:45 AM
OW encoding weirdness with MT Gregory OmniWeb Bug Reports 0 2006-11-17 07:38 PM

All times are GMT -8. The time now is 11:10 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.