The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
preventing omnifocus from starting up by itself Thread Tools Search this Thread Display Modes
Hello,

I have omnifocus on Mac and iPhone, they sync through mobile me.

Omnifocus on the Mac, starts up with login. But if I quit, it starts up later by itself in hidden mode.

Is there a way to prevent omnifocus from starting up on it's own? (not just at login but just randomly during the day)
Is syncing responsible for this?

Thanks,
 
Odd that it always starts up by itself. I never see this.
 
Syncing wouldn't do this (OmniFocus doesn't sync as part of MobileMe sync or anything, and doesn't sync itself when it's not running).

Do you perhaps have a Dashboard widget that talks to OmniFocus? If so, that could explain if OmniFocus launches when you activate Dashboard.

Alternatively, if you're invoking the "Send to OmniFocus" Service from Mail or your web browser, etc., that will cause OmniFocus to launch (but presumably it wouldn't be a mystery to you in that case).

Or, if you have a mail rule defined to create OmniFocus actions from certain incoming mail, that would explain it.

Those are the possibilities that come to mind, although it seems to me I've heard of some other process that can cause this, but I can't remember it at the moment (or maybe I'm just imagining it).
 
Thank you,
I diabled MobileMe syncing form inside OmniFocus yesterday and it hasn't started up on it's own yet (not enough time to tell).
I just removed the dashboard widget. I'll try to see which one is responsible...
I don't have anything else set up with it so it has to be one of these 2.

I'll post a reply if I find a solution.

Thanks again,
 
Quote:
Originally Posted by counterpt View Post
Thank you,
I diabled MobileMe syncing form inside OmniFocus yesterday and it hasn't started up on it's own yet (not enough time to tell).
Actually, there is -- the syncing is done by OmniFocus, and you can change the files on the MobileMe server as much as you like with OmniFocus not running without causing it to launch, because there is no mechanism there to see the changes, to put it simply. The sync mechanism only runs when you have OmniFocus running already.
Quote:

I just removed the dashboard widget. I'll try to see which one is responsible...
I don't have anything else set up with it so it has to be one of these 2.
You can also get OmniFocus to start up by running an Applescript that mentions it, or double-clicking one of its data files, or a perspective file, or a theme file, to name a few things that come to mind. A bit more unlikely, but not impossible, is that you've somehow managed to get some other file or file type set to be opened with OmniFocus, which would cause it to launch when opening the file(s).

One thing I observed in a past life doing computer support was that people often do things without being aware that they have done so (especially, but not limited to, people who were not first and foremost "computer people"). Sometimes they even become quite hostile when this is demonstrated by looking at history logs and the like :-)

Quote:
Omnifocus on the Mac, starts up with login. But if I quit, it starts up later by itself in hidden mode.
Can you be a bit more specific about exactly what you mean by "quit" and "starts up later in hidden mode"? That sounds suspiciously similar to what would happen if you "quit" by closing the OmniFocus document window by clicking the red close button (which doesn't quit the application at all, thus leaving it running for you to "discover" it running in "hidden mode" later).

Can you boot your computer before going to bed, quit OmniFocus (and verify with Activity Monitor that OmniFocus is no longer running), set the Energy Saver preferences so the computer will not go to sleep, and come back hours later to find OmniFocus running again?
 
Quote:
Originally Posted by counterpt View Post
Thank you,
I diabled MobileMe syncing form inside OmniFocus yesterday and it hasn't started up on it's own yet (not enough time to tell).
I just removed the dashboard widget. I'll try to see which one is responsible...
I don't have anything else set up with it so it has to be one of these 2.

I'll post a reply if I find a solution.

Thanks again,
Oh, you're running OmniFidget?

That's what's doing it... when 'Fidget has to find the tasks, it has to open OmniFocus to get the data.

If you don't want OF to launch, don't use 'Fidget.
 
Quote:
Originally Posted by CatOne View Post
Oh, you're running OmniFidget?

That's what's doing it... when 'Fidget has to find the tasks, it has to open OmniFocus to get the data.

If you don't want OF to launch, don't use 'Fidget.
Yes you are right. Thank you. I disabled the widget, and now the program doesn't launch itself.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fresh start/Starting over (Resetting OmniFocus to default data) [See thread.] Phibermaster OmniFocus 1 for Mac 8 2012-08-31 04:12 AM
Starting a basic Workflow with OmniFocus tjslogic Applying OmniFocus 3 2011-04-18 07:09 PM
Starting Over with OmniFocus: Mac + iPhone danglickmd Applying OmniFocus 3 2010-04-05 05:08 PM
OmniFocus not syncing; hanging; not starting; etc DragonDave OmniFocus for iPhone 3 2008-09-03 08:20 AM
Preventing unnecessary refreshes robertm OmniWeb General 0 2007-01-19 09:06 AM


All times are GMT -8. The time now is 11:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.