The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPad
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Bug or my screw-up? Thread Tools Search this Thread Display Modes
I was trying out the review feature on the iPad. I don't remember exactly what I did, but remember toggling the big buttons on the bottom. I finished the review session and moved back to look at the contexts view. Low and behold, some 400 of my past tasks reappeared as unchecked in the single actions folder. Apparently Omnifocus then synced with my webdav server, because I tried restoring the last version on the server to no avail. I went to the desktop, opened it up and it grabbed the latest version of the db, showing the 400 incomplete tasks, separated into 3 "single actions" folders (I used to have only one of them like everyone else).

Restoring from yesterday's backup and resyncing did not cure the problem - it synced up with the database and brought all the refuse back. So I manually selected all the tasks and deleted them, followed by a sync.

Did I do something wrong?
 
Quote:
Originally Posted by Crimguy View Post
Did I do something wrong?
Yes, you posted in the OmniGraffle for iPad forum instead of OmniFocus for iPad :)

I can't figure out what you might have done in the review tool to cause any of this, or even imagine what sort of plausible bug might have caused it. You should contact the support ninjas when they open for business at 10AM (80 minutes from now) at 1-800-315-OMNI and see if they can help you get to the bottom of this.
 
Hey Crimguy. The _only_ thing I can think of (other than a bug, of course), would be marking a repeating project as completed, then as active, and repeated. (You say you had 3 SAL projects?)

Otherwise, perhaps write in with a backup attached? Support
 
Attaching a back up will be a problem. I'm an attorney, and there is a lot of privileged information in there.

I'll ignore and hope it doesn't happen again.
 
It would be nice to have an "Export Database as Anonymous Debug" feature where all of your actions were translated into some other name suitable for debug, but where nothing of yours would get shows.

For example:

- Super Secret Project Must Ship Before Competition
- Super Secret e-mail based Action 1
- Super Secret vendor agreement action 1

Got translated into

- Project432
- Project432:Child1
- Project432:Child2

Totally off topic, but related to your problem. I can't send my database to Omni either. I don't even want to sync my database to the Cloud.
 
I've suggested they should implement something like the data scrambler in OmniPlan for just this reason, but it hasn't risen to the top of the to-do pile, obviously. If such a feature is of value, vote early, vote often, Help->Send Feedback or Contact Omni or omnifocus@omnigroup.com...
 
Quote:
Originally Posted by blewis View Post
Totally off topic, but related to your problem. I can't send my database to Omni either. I don't even want to sync my database to the Cloud.
Me neither. I can't email my OF database, and syncing does not appeal to me at all (unrelated to sensitive information). This is a big problem for me, because it is the only way I trust to backup my database. I do not want to sync (I'm a touch-only/PC user), but am considering doing omnisync until this is resolved.

I've restarted my Touch, rebuilt my and compressed my database, all to no avail. After pressing "invoke and quit", the compose email dialog pops up, but after a few soconds, crashes and goes away. :(

I've reported it to the ninjas. If this is also happening to you, write them yourself, please.
 
You should be able to retrieve it through iTunes now that they have enabled file sharing in 1.7.1 and later. The file you get out is exactly what would be mailed or synced.
 
Quote:
Originally Posted by whpalmer4 View Post
You should be able to retrieve it through iTunes now that they have enabled file sharing in 1.7.1 and later. The file you get out is exactly what would be mailed or synced.
Good to know. I'll take a look.

Thanks for the advice.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thumbnail screw up Forumposter OmniWeb Bug Reports 1 2009-08-05 09:46 AM
Version compatibility: did I just screw up? Forrest OmniGraffle General 5 2006-05-03 10:18 PM


All times are GMT -8. The time now is 11:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.